Forbidden. You don't have permission to access /nagios/


#1

Hi,

Can any one help me please ?

When I browse nagios site, I get following error.

Forbidden
You don’t have permission to access /nagios/ on this server.


Apache/2.2.4 (Fedora) Server at 172.16.150.8 Port 80

I tried Nagios 2.9 and 3.03b on Fedora Core 7.90. both versions of nagios shows me same error.

Following are details of nagios config.

===================================================================
[root@proxy bin]# ./nagios -v /usr/local/nagios/etc/nagios.cfg

Nagios 3.0b3
Copyright © 1999-2007 Ethan Galstad (nagios.org)
Last Modified: 08-30-2007
License: GPL

Reading configuration data…

Running pre-flight check on configuration data…

Checking services…
Checked 8 services.
Checking hosts…
Checked 1 hosts.
Checking host groups…
Checked 1 host groups.
Checking service groups…
Checked 0 service groups.
Checking contacts…
Checked 1 contacts.
Checking contact groups…
Checked 1 contact groups.
Checking service escalations…
Checked 0 service escalations.
Checking service dependencies…
Checked 0 service dependencies.
Checking host escalations…
Checked 0 host escalations.
Checking host dependencies…
Checked 0 host dependencies.
Checking commands…
Checked 24 commands.
Checking time periods…
Checked 5 time periods.
Checking for circular paths between hosts…
Checking for circular host and service dependencies…
Checking global event handlers…
Checking obsessive compulsive processor commands…
Checking misc settings…

Total Warnings: 0
Total Errors: 0

Things look okay - No serious problems were detected during the pre-flight check
[root@proxy bin]#

Nagios service starts seamlessly

service nagios start

=======================================================
Nagios directory status

drwxrwxr-x 2 nagios nagios 4096 2007-09-19 03:21 bin
drwxrwxr-x 3 nagios nagios 4096 2007-09-19 18:05 etc
drwxrwxr-x 2 nagios nagios 4096 2007-09-19 03:31 libexec
drwxrwxr-x 2 nagios nagios 4096 2007-09-19 03:21 sbin
drwxrwxr-x 9 apache nagios 4096 2007-09-19 03:31 share
drwxrwxr-x 5 nagios nagios 4096 2007-09-19 18:58 var

apache and nagios is in group nagios

Httpd error log

[client 172.16.150.235] Options ExecCGI is off in this directory: /usr/local/nagios/share/
[client 172.16.150.235] Options ExecCGI is off in this directory: /usr/local/nagios/share/

==========================================================

I tried putting " Options ExecCGI " in Alias directive, I found following erro

[error] [client 172.16.150.235] Options ExecCGI is off in this directory: /var/www/html/favicon.ico
[error] [client 172.16.150.235] attempt to invoke directory as script: /usr/local/nagios/share/

I don’t understand, why its trying to access /var/www/html/favicon.ico. :o)

Nagios.conf file

ScriptAlias /nagios/cgi-bin “/usr/local/nagios/sbin”

<Directory “/usr/local/nagios/sbin”>

SSLRequireSSL

Options ExecCGI
AllowOverride None
Order allow,deny
Allow from all

Order deny,allow

Deny from all

Allow from 127.0.0.1

AuthName "Nagios Access"
AuthType Basic
AuthUserFile /usr/local/nagios/etc/htpasswd.users
Require valid-user

Alias /nagios/ “/usr/local/nagios/share/”
#Alias /nagios “/usr/local/nagios/share”

<Directory “/usr/local/nagios/share”>

SSLRequireSSL

Options ExecCGI
Options None
AllowOverride None
Order allow,deny
Allow from all

Order deny,allow

Deny from all

Allow from 127.0.0.1

AuthName "Nagios Access"
AuthType Basic
AuthUserFile /usr/local/nagios/etc/htpasswd.users
Require valid-user

I can view following

172.16.150.8/nagios/cgi-bin/summary.cgi

Even try with other cgi files, it do work also.

Thanks in advance

Splfriends


#2

You didn’t follow nagios very well. It’s supposed to be:

Alias /nagios /usr/local/nagios/share
<Directory “/usr/local/nagios/share”>
Options None
AllowOverride AuthConfig
Order allow,deny
Allow from all

But perhaps your SElinux firewall is blocking access?

run
system-config-securitylevel