Getting errors when starting httpd


#1

Hello,

I’m fairly new to FreeBSD and nagios but I am trying to install nagios on a FreeBSD 8.2 and it’s not working very well.
I’m editiong the /usr/local/etc/apache22/httpd file to tell Apache about nagios as the following

ScriptAlias /nagios/cgi-bin /usr/local/www/nagios/cgi-bin
<Directory “/usr/local/www/nagios/cgi-bin”>
AllowOverride AutoConfig
Options ExecCGI
Order allow,deny
Allow from all

Alias /nagios /usr/local/www/nagios
<Directory “/usr/local/www/nagios”>
Options None
AllowOverride AutoConfig
Order allow,deny
Allow from all

When I restart Apache it gives me the following error

hostname# /usr/local/sbin/apachectl restart
Syntax error on line 307 of /usr/local/etc/apache22/httpd.conf:
Illegal override option AutoConfig
httpd not running, trying to start

I tried with AllowOverride None and it also didn’t work.

Could anybody provide a kind of a step-by-step guide to installing nagios on FreeBSD?

Also, I know that there are some web based front end to nagios. Could someone please recommend a good one that is also easy to install?

Thank you,


#2

you sure you wanted AutoConfig and not AuthConfig ? (searching on googl epoints to this error, not sure why it wouldn’t work witn None, though… )

Try having a look at the apache logs. maybe there’s some extra bit of info :wink: