Having problem viewing CGI files in browser



I have set up Nagios 3 on FreeBSD 8 and Apache 2. I haven’t set up any authentication on my apache configuration or nagios configuration file. When I run my browser I can see the front page of Nagios, but whenever I try to click on a report page, browser tells me that it can save the CGI file (as a download) and I can’t browse the content of the report on my browser.



looks liek a missing perl interpreter… tre cehckign the config.log file in the source directory.


Commander Luca, how can I tell perl to interpret the cgi files correctly? Is there any command for it?


Luca… I couldn’t find the file that you said… meanwhle when I try to run some of cgi files of nagios by Perl in command prompt I got this error message which says "Unrecognized character \x7F in column 1 at avial.cgi line 1."
Any idea what the hell is wrong with it?


Commander Luca, I finally solved the problem. Here is what I did!
I had to add “AddHandler cgi-script .cgi” to my httpd.conf for my apache 1.3! Now I can see CGI files…