HELP! Im going nuts with this


#1

Would really appreciate some input on my issues

im running the latest flavour of fedora, nice fresh installation.

started by installing nagios 2.0b2 from source, no problems with compile, made config files, installed exactly as per docs, ran nagios -v and showed no errors (well it did obviously first up but i fixed up them all)

so 0 errors and 0 warnings

webpage works fine

but when i try and access any of the cgis from the page i get:

Could not read host and service status information!

i am able to access the normal cgis down the bottom of the side.html,such as event log, config but the executable ones simply will not run

i have since done aonother fresh install of fedora and tried nagios 1.2 stable, and same problem

ive been at this for 3 days straight now, my hair is falling out and i have deadlines!!!

somebody please help!

thank you in advance

Dave


#2

check if the status.dat file is created in your nagios/var directory and if you have defined it correctly in your nagios.cfg file by:

STATUS FILE

status_file=/usr/local/nagios/var/status.dat


#3

status file location was defined properly but the status file its self doesnt exist

i created a dummy file just to see but no luck

when i do run nagios from the command line without -d, is it supposed to read:

Nagios 1.2 starting… (PID=5228)

and just hang there?


#4

I think you missed this in the docs.
nagios/docs/commandfile.html
It goves step by step on how to configure the rw directory.


#5

solved my problem,

wasnt a problem with permissions

the config file refers to status.dat

but my install created status.sav

so i renamed the reference in nagios.cfg to look for status.sav instead

restart

and wham bamm im ur man

it worked.

hence the ear to ear grin on my face finally after nearly a week


#6

Now get nagiostat running, then you will really get a thrill.