Host DOWN problem with remote servers


#1

Hi All,

I’ve been wading trough this forum a bit to find a solution for this problem.

I have a couple of hosts set up in nagios 2.9. When I launch nagios it does not report any problems so my setup is fine.

Some of them are internal servers, others are remote.

The remote servers all show up as critical in the Hosts problems section, but not in the services section. I suspect this has something to do with these hosts not being able to reply to ping requests.

Is there a way to disable host checks for a certain group, and if yes, how?

Thank you,

Frederik


#2

Yes, there is an option you can add to host definition:
active_checks_enabled [0/1]
where 0 means disable, and 1 enable. I suppose you have to use 0.


#3

I have tried adding this to the appropriate service defenition.

I have created a separate hostgroup, service groups, service template with disabled active checks, and my host still comes up as “Host Down”. Is there a way to get it back to Host UP so that what I see in the nagios interface is what I really have, a host that is up?


#4

You should add it in the host definition:
define host{
name virtual-host
active_checks_enabled 0

After the change above, and if your services are UP, your hosts should become UP as the services are checked (I said “should”; if not, try stopping nagios, deleting the log file that retains the state of your hosts, and restart nagios … that’s not really subtle, but it should work:))


#5

I’ve tried restarting, and the hosts show up as disabled in the interface. They still show up as being down, though. Which logfile should I delete?