Host error: Host Check Timed Out


#1

Hello,

I had my first encounter with Nagios today. I set up a server, it monitors itself, I configured a Windows server to be monitored successfully (in the same LAN). Then I configured a remote Ubuntu machine at home (via WAN), setup NRPE and I can monitor services successfully.

The main problem is that Tactical overview shows the remote Ubuntu machine (host) as down with error (Host Check Timed Out). How can I solve this?

BR Aleš


#2

When was the last host check done? try forcing a host check.


#3

Hello,

last check is done all the time. I also tried to do a force check but it doesn’t work. I did my own “little experiments” to test the checks and on localhost and machine in LAN it all works great. Services, processes, everything is detected normally. But on this machine which is controlled over WAN I have problems with just this host check. But I don’t understand how can host check be timed out and on the other side… all other checks (services, disk space, …) is checked perfectly!

Please help :slight_smile:


#4

The point is host checks should not be performed if service checks don’t fail…
from your nagios server can you ping your home server correctly from comand line? does the check work correctly from command line (as user nagios?)


#5

Thanks for that information. One service did in fact fail to check so I will check that. But I can ping my router actually normally… My setup is like this:

Nagios server -> router -> WAN -> router -> monitored Linux machine

nrpe_check is successful when I do it from Nagios server to my monitoring machine. I’ll check the other service check that fails and I hope that fixes it.


#6

Ok, me again. I checked that all processes check OK. But I still get the mentioned host error. Any other ideas?


#7

if one service fails, nagios makes the host check, but it shouldn’t fail if you can ping it.
Check what hostcheck you have (usually it’s check_icmp or check_ping) and try to use that command from command line. possibly one of the routers is blocking something exactly on that check.


#8

Well, I found the problem. The router/modem that my ISP assigned to me doesn’t allow pings from WAN and it doesn’t have a current software option for that… I suppose there isn’t really any other way to do that? Can I somehow redirect ping like forward ping request to my server in LAN after this router/modem via nagios?


#9

Create a new check host command definition and use another type of check to check the host is online… it’s not the same but at least the host will appear as UP…


#10

Well, thank you very much. I solved the problem by creating a new command which checks ssh. However I will check how other people do their host checks with this setup. If you have any recommendations please point me in the right direction.

BR


#11

there’s not much you can do… you need the check with the highest “availability”.
either you get a way to have a ping through the router/firewall or you are a bit stuck :slight_smile:
Possibly some firmware update? if you can get ssh or http to pass thorugh it should be possible to have icmp enabled too somehow :slight_smile:


#12

Well, thank you very much :slight_smile: