I get an error when I do a make of NRPE


#1

Here is the error I get below when try to do a make after I the configure ran without a problem.
What am I missing? Do I have to install openssl?
check_http.c: In function âprocess_argumentsâ:
check_http.c:312: error: âssl_versionâ undeclared (first use in this function)
check_http.c:312: error: (Each undeclared identifier is reported only once
check_http.c:312: error: for each function it appears in.)
make[1]: *** [check_http.o] Error 1
make[1]: Leaving directory `/var/tmp/nagios-plugins-1.4.16/plugins’
make: *** [all-recursive] Error 1
[root@ct-eng-amq01-devint nagios-plugins-1.4.16]#


#2

I installed openssl and I re-configured and ran the make again which failed with the same error.


#3

I got nagios plugin and nrpe install on the client by using a different version of the software. I made the necessary changes to get the nrpe software and opened up port 5666 on it. I ran commands to make sure nrpe was running ok. I then install nrpe_check on the Nagios server and made the necessary changes to get it working. I opened up the port 5666 and restarted the Nagios processes. I then ran Nagios commands to see if the Nagios server can talk to the client and all the commands were successful. The problem is I am not seeing the remote client in the Nagios page when I run ](http://)/nagios after serveral hours. I click on host and only see the local server. What am I doind wrong or have not done?

Thanks in advance for your help