Insall problem, libttf.so.2 missing


#1

Hi all,
I try toinstall nagios 3.0 on a CentOs 5 using YUM.

I added the rpmforge repositories and when i launch a nagios install :
YUM INSTALL NAGIOS NAGIOS-PLUGINS NAGIOS-PLUGINS-NRPE NAGIOS-DEVEL

i get an error message : “libttf.so.2 is needed by package nagios”

Should normaly YUM not take care of all dependencies ?

I tried to find what package has libttf.so.2 with YUM WHATPROVIDES libttf.so.2 , but YUM deos not find it…

Any help … ?? What package is installing this libttf.so.2 file ? Why is YUM not installing it if it is needed ?

Thanks,


#2

Hi

YUM can’t find it because, being part of freetype 1.x, it has been deprecated since the introduction of freetype 2.x - looks like nagios has been packaged incorrectly as it really shouldnt be looking for it in the first place. Your best hope would be to locate the most recent tarball of freetype 1.x you can find for centos/fedora/redhat and install it manually. Might work, might not. Maybe you will then need to add it to ld.so.conf and run ldconfig too.

HTH
/S
[Edit: Or, just install nagios manually instead of using YUM… it’s easy enough if you follow the [url=http://nagios.sourceforge.net/docs/3_0/quickstart-fedora.html]fedora instructions]


#3

Hi !
Thanks for the reply.
I think i was victim of a serial bug… WHen i tried to install, the rpmforge dns was down and i think there were some problems.
Next morning, i tried again and it worked first time ! No more dependencies problem !
But i noticed that rpmforge has Nagios 2.11 not 3.0 and i had some problems running the nagios service.

I uninstalled everything and installed it manualy. It worked just fine after installing the gcc library.

Thanks,
Patrick