It appears as though Nagios is not running, so commands are


#1

…is the message.

I know that this has been discussed severall times…Unfortunately i read many of them and didn’t solve my problem.

Ok, the facts: I installed nagios 1.2 with MySQL-db. As i can see on the perfdata, logging of them works. Nagios-plugins are 1.4.2.

If i try “check_nagios_db.pl” as root or nagios, it works!
What do you need else to help me?

Can someone help me out step by step? I soon need to have the management-options in nagios that are provided by this feature…

Kind regards, Qeldroma
Edited ]


#2

is nagios in fact running?
ps -ef | grep nagios
looks like it does as yiou have perfdata… possibly the command file permissions?

Luca
Edited Mon Dec 05 2005, 03:23AM ]


#3

yes, it is:
9804 nagios nagios 9804 /usr/nagios/bin/nagios -d / S ? 00:01:02 /usr/nagios/bin/nagios -d /etc/nagios/nagios.cfg


#4

This is my nagios check command in cgi.cfg. Try it.
nagios_check_command=/usr/bin/perl /usr/local/nagios/libexec/check_nagios_db.pl
There is a space between perl and /usr and that is all one line.


#5

Oh well, yes, i tried it like this, mine is with leading “/usr/lib/perl”, too…

Inbetween i changed it to World-read/write/executable. No influence, error keeps on…


#6

Oh, now it works, but all i did was restarting the server:?::?:?

Hum… seems that restarting the nagios and the apache is not enough to reset the sytem to the actual config…

Thanks so far, Qeldroma


#7

Yes, restarting nagios, apache and maybe mysql is all that is involved. I suspect, that you have more than one nagios installation.