It appears as though you are not authorized


#1

Hi,

I have been using Nagios for about a year now and i have just upgraded to version 3 from 2.9. However i have come across a problem “It appears as though you are not authorized to view information for the specified host…”. This problem occurs when trying to access a trend report under the trend page.

This is the howto i have been using to install Nagios ubuntuforums.org/showthread.php?t=223498

Can anyone help me please? Happy to supply any info if required.

Regards,
Sam


#2

I have the same problem too.


#3

I have found some other people who have the same problem. translate.google.com/translate?h … n%26sa%3DN

But they say its been reported on Nagios devel and the problem didn’t exist in RC2.


#4

Does anyone else have this problem or know of a fix/work around?

Ive got some good data that i would like to trend :slight_smile:


#5

Same problem here, running Nagios 3.0 stable


#6

According to the link you need to download and install a new version of trends.cgi, does anyone have one that works they can post or show me where one is.


#7

I will have a go at downloading 3rc3 and installing it on a test machine and copying the trends.cgi file to my production machine and see what happens.

If it works i will post the file if i can.


#8

Nagios 3.01 has been released.

Change Log:
Fixed bug in trends CGI with user not being authorized for hosts/services.
Fixed bug in status CGI with page layout messing up when sounds enabled .

Sounds like the fix we have been waiting for :slight_smile:


#9

I had the same problem on version 3.0.3. I found that if any services I try to change the trends time period on has a space in the name, the update does not get directed to the proper device name. If you watch the name closely you will see the name change, and you will get the “it appears you do not” message. If you remove the spaces all works fine.


#10

Just downgrade your current version e.g “Nagios 3.0RC3” and problem will resolve in minutes