It appears as though you do not have permission to view


#1

I encountered no errors when installing Nagios 3.0.3 on Mac OS X Server (10.5 Leopard). Now when I attempt to view pages, I get the following…

“It appears as though you do not have permission to view information for any of the hosts you requested…
If you believe this is an error, check the HTTP server authentication requirements for accessing this CGI
and check the authorization options in your CGI configuration file.”

I have checked and rechecked all permissions for the WebServer and the Nagios folder. All are owned by my nagios user with www as the group. Permissions are 777. What am I missing?

Thank you!!


#2

Hi!

In fact, the permissions you should check are:
-those in cgi.cfg (if you want to test quickly, define all the options that start by “authorized_for” to ""; ie: authorized_for_all_services= ; after that, if you can view the pages, you’ll have to fine tune a little bit more, except if you don’t care about security)
-maybe some in your apache config file


#3

I changed the authorized items to * and nothing has changed. In addition there are a few graphics that show up as ‘?’ I triple checked permissions and I am still OK there. Is there another location that defines locations of graphics or other files that might need to be changed?