KVM clocksource


#1

Hi all,

I am sorry for any mistakes. This is my first post.

I am developing a system in which we don’t want to synchronize the system time of the VM to the host after resuming (not restarting). We used the -rtc clock=vm option but it does not work. The hardware clock of the VM stops synchronization (checked by hwclock command), but the VM system time is still updated accordingly to the host system clock (checked by** date** command).

I am not much familiar to Linux kernel, so I have two confuses:

  1. Why the VM system time updated according to the host system time? It should be updated according to its own hardware clock right?
  2. So, is it the bug of -rtc command for not behaving as it should? Or the system time synchronization is a must-happen process, and it is impossible to disable it?

Please, I need your help.
In case you think this is not an appropriate place to ask this type of questions, could you please suggest me other places?

BR,