Last Check Column not Updating in Host Detail



I’m a real new user to Nagios. However, I do think it’s a great product. Inadvertently, I installed 2.0.4b. I’ve come to understand that I should have stuck with 1.2, as 2.x is still somewhat buggy. In any case, I’m just playing with it for now, so it’s no big deal (I hope).

Now, to my question:

On the “Host Detail” page, the “Last Check” column doesn’t seem to be updating properly. When I reload the page, I figured that it’d show the last time that the check-host-alive program ran. However, it’s running every 120 seconds, but it hasn’t updated since yesterday when I fixed an error that made everything go to a “Down” state (oops). Anyway, if I go in to the Host Group Overview, I can see that the “Service Status” does show the correct time for last check.

Any thoughts?




In nagios v1.2 hosts are NEVER checked unless a service fails. But since you are using the beta, it’s possible to perform host checks on a regular basis. I have to assume that there is a link in the “Host State Information” that will allow you to toggle active checks on or off, just like you have in the “Service State Information” in v1.2.
So, clik the link to enable host checks. … .html#host
max_check_attempts =?
You have set all these per the docs right?
If so, then you must not have done this: … tion_notes
What that last link says in short, is what I stated up above. Clik the link to disable/enable checks EVEN IF you have checks enabled in your config files. This is due to retention.


BTW, I find this completely redundant to perform a host check on a device that I have already checked the ftpd service, or disk space, or fping, etc. If the service check works, obviuosly the check-host-alive will work also. But if a service check of the ftpd fails, then at least, we want to know if the host will ping. Only in the event of a service failure, would I ever want to utilize nagios cpu time to make a host check.

The above will become extreamely important when you are monitoring over a 1000 services and I suggest you form good habits now, and save yourself the trouble of changing your config files in the future. Not only will you have to change your config files, you will have to use the web interface to disable these active host checks due to retention, also explained above.

In other words, leave it how you have it now. It’s better that way.


Thanks for your advice. I do see your point.




As long as services are checked at regular intervals there is no problem.
I checked on my install (2.0b4)…
Hosts are checked only when services fail… and on startup… that’s why they updated once… and not thereafter :smiley: