Lilac, a configuration tool for Nagios 3 has released it


#1

Lilac, a configuration tool which was derived from Fruity, a popular
configuration tool for Nagios, has released it’s first alpha release.
This release can be downloaded to create new Nagios configurations and
manage them. It supports all of Nagios’s object types as well as
multiple inheritance. Lilac goes a step further with templates and
lets you bind services, escalations and dependencies to host templates
as well. The alpha release features a rich exporter system as well.
The first alpha release does not have a completed configuration
importer (but does come with a basic Nagios configuration to start
from), nor does it have the auto-discovery feature. Those will be
provided in the next Alpha release. For now, Lilac needs people to
test the functionality of the UI and file bug reports or feature
requests to help make Lilac the best configuration tool out there for
Nagios.

For more information, take a look at the Lilac homepage at
lilacplatform.com for download links, basic install
documentation, forums, and issue tracking.

Thanks all, and for those who knew about this project, it’s been a
long time coming!

Taylor


#2

I see beta 1 has been released 12 days ago. This first beta of Lilac Configurator 1.0. includes a robust Nagios Configuration Importer, Auto-Discovery system and Exports to Nagios 3.x systems, according to the downloads page.

Has anyone here tried Lilac? Who wants to share their experiences? :?:


#3

Looks nice, Gona try this first on a test server before in implement it in the live environment.
But it looks promising. thx for the tip.


#4

Seems very good, like the autodiscover function. Will report back.


#5

You like that it has autodiscover in its feature list? Or have you actually experienced this feature? 8)


#6

I just got Lilac running and I went straight for the “Auto Discovery” bit… It broke :confused:

Warning: require_once(PEAR.php) [function.require-once]: failed to open stream: No such file or directory in /var/www/lilac/library/Net/Traceroute.php on line 39

Fatal error: require_once() [function.require]: Failed opening required ‘PEAR.php’ (include_path=’/var/www/lilac/includes/…/library/:/var/www/lilac/includes/…/classes/:.:/usr/share/php:/usr/share/pear’) in /var/www/lilac/library/Net/Traceroute.php on line 39

*EDIT- fixed, was missing php-pear… duh

**EDIT - still broke :confused:

2009-02-05 14:36:03

ERROR

Engine autodiscovery process failed to complete successfully.
2009-02-05 14:36:03

ERROR

Nmap failed to complete successfully. Aborting discovery.
2009-02-05 14:36:01

NOTICE

Executing nmap via: sudo /usr/bin/nmap --max-rtt-timeout 100 --max-retries 0 -sS -O -A -v -oX /tmp/2-nmap.xml 10.10.10.0/24
2009-02-05 14:36:01

NOTICE

Starting discovery…
2009-02-05 14:36:01

NOTICE

Removing potential old job files.
2009-02-05 14:36:01

NOTICE

Initializing Auto Discovery Engine: NmapAutoDiscoveryEngine
2009-02-05 14:36:01

NOTICE

Removing old devices found in this job.
2009-02-05 14:36:01

NOTICE

Starting Background Auto Discovery Process for Job: LAN Scan


#7

Well, I tried this webpanel, but the import feature isn’t working well… atleast at my nagios server :roll:
50% time it says:
Current Status: Failed - Engine import process failed to complete successfully.

the other 50%:
2009-04-22 15:48:12 NOTICE NagiosCommandImporter finished importing command: check_snmp
and keeps “running” forever… I checked it, check_snmp exists in the libexec of nagios, someone can help me? :cry: