Nagios 1.2 on gentoo


#1

I am a newbie to this i am taking over a net admin position and know nothing about gentoo. Nagios is running but does have some problems. the email notification does not seem to work since nagios was installed on gentoo. I also am getting this error as well (Bailing out due to errors encountered while trying to open the external command file for reading)(Error: Could not create external command file ‘/usr/local/nagios/var/rw/nagios.cmd’ as named pipe: (17) -> File exists. If this file already exists and you are sure that another copy of Nagios is not running, you should delete this file.) When i delete the nagios.cmd file nagios works fine. I know in redhat you need to add a group and the apache and nagios users with permissions for this not to happen. i have no idea how to do this in gentoo…any help would be awesome. :evil:


#2

gentoo is about the same as any other 'nix. It sounds like you aren’t into Linux very much. The nagios documentation walks you through the steps so well, that even a linux illiterate can follow them. That is of course assuming you know how to use the “cd” command, and perhaps some others.

But honestly, the docs tell you how to setup the rw directory, and everything else, so please give them a try.

If there is anything in particular you can’t figure out from the docs, then I’d be happy to help.

Notifications, first let’s see if you can execute the command to send an email, just like nagios will do.

su - nagios
/usr/bin/printf “%b” “Nagios” | /bin/mail -s "alert " [email protected]


#3

i did get an email but still no e-mail from the notifications??


#4

did get an email but still no e-mail from the notifications??


#5

Again, it sounds like nagios is not even running, since it said “bailing out”. YOu need to get it running first, to get notifications. The docs show how to run it to check for errors. Do you get any errors when you do that?


#6

the bail out is fixed i deleted the nagios.cmd and it is working fine now…excetp the notifications are not working. the ping checks and everything is working great.


#7

Ahhh yes, forgot about this one.
For your enjoyment, read the following.
nagios.sourceforge.net/docs/1_0/xodtemplate.html
"It is important to point out that several directives in host and service definitions may not be picked up by Nagios when you change them. Host and service directives that can exhibit this behavior are marked with an asterisk (*). The reason for this behavior is due to the fact that Nagios chooses to honor values stored in the state retention file over values found in the config files…" “you can issue the appropriate external command or change the value of the host or service directive via the web interface, so that it matches what you’ve changed it to in the config files”

So in other words. Even though you have the config file set to “notifications_enabled” for a service, it will still not notify you, due to the state retention. So use the web interface, and clik on the service/host and enable notifications. While you are at it, clik on any others that may be important to you, like dissable flap detection, etc.


#8

i did that already but still not notifying me. i guess send mail may not be working correctly


#9

If you did the above succesfully, then mail is working. "su - nagios
/usr/bin/printf “%b” “Nagios” | /bin/mail -s “alert " [email protected]

Check your configs to make sure you are even supposed to get notified. Maybe you are not a contact for that host.