Nagios 3.0.1 - Could not read object configuration data! sta


Hi all,

I decided to upgrade from a previous version of Nagios (version 2.10) to the latest version available (version 3.1.0).
I followed the instructions from the Nagios Content help explicitly, found here: , everything went fine except that I cannot display the statusmap.cgi and the histogram.cgi pages. All of the other cgi 's work fine, so I don’t think it can be the original problem that I had that is mentioned all over this forum here:

The cgi files do exist in the directory /usr/local/nagios/sbin and I have setup all the users and permissions and verified them and they are correct. I also do not get any compilition errors like before, where it was missing the gd library and some of the other libraries, this was in the previous version 2.10 and I had fixed this similar issue. I also read on the forum to run this command to verify the libraries and there locations ( ldd statusmap.cgi ) and here is the output verifying that it is ok: => /usr/lib64/ (0x00002abb19297000) => /usr/lib64/ (0x00002abb194eb000) => /usr/lib64/ (0x00002abb19711000) => /usr/lib64/ (0x00002abb19937000) => /lib64/ (0x00002abb19b59000) => /lib64/ (0x00002abb19d6e000) => /lib64/ (0x00002abb19fc5000) => /usr/lib64/ (0x00002abb1a307000) => /usr/lib64/ (0x00002abb1a518000) => /usr/lib64/ (0x00002abb1a853000) => /usr/lib64/ (0x00002abb1aa87000)
    /lib64/ (0x00002abb19079000) => /lib64/ (0x00002abb1ad03000) => /usr/lib64/ (0x00002abb1af1e000) => /usr/lib64/ (0x00002abb1b121000) => /lib64/ (0x00002abb1b328000) => /usr/lib64/ (0x00002abb1b52c000)

I ran the pre-flight check and all checks out fine, here is the output:

VSAS4:/usr/local/nagios/sbin # /usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg

Nagios 3.0.1
Copyright © 1999-2008 Ethan Galstad (
Last Modified: 04-01-2008
License: GPL

Reading configuration data…

Running pre-flight check on configuration data…

Checking services…
Checked 93 services.
Checking hosts…
Checked 28 hosts.
Checking host groups…
Checked 14 host groups.
Checking service groups…
Checked 13 service groups.
Checking contacts…
Checked 2 contacts.
Checking contact groups…
Checked 2 contact groups.
Checking service escalations…
Checked 0 service escalations.
Checking service dependencies…
Checked 0 service dependencies.
Checking host escalations…
Checked 0 host escalations.
Checking host dependencies…
Checked 0 host dependencies.
Checking commands…
Checked 28 commands.
Checking time periods…
Checked 4 time periods.
Checking for circular paths between hosts…
Checking for circular host and service dependencies…
Checking global event handlers…
Checking obsessive compulsive processor commands…
Checking misc settings…

Total Warnings: 0
Total Errors: 0

Things look okay - No serious problems were detected during the pre-flight check

I also checked the nagios.log and the apache error log and couldn’t find anything useful as to why I am getting this error. What’s strage is that all the other cgi 's work on the reporting section, just not the statusmap and histogram.
Any suggestions would be greatly appreciated. I spent hours reading the forum for similar posts but have not found one pertinent to this version or this particular type of issue.

I have also stopped and re-started both Nagios and apache and cleared the web cache to make sure that nothing is being cached. I can succesfully start nagios and everything works great, it’s just only those 2 CGI’s that won’t display.

SAS4:/usr/local/nagios/sbin # ps aux | grep nagios
nagios 28862 0.0 0.0 26660 1440 ? Ssl Apr18 1:14 /usr/local/nagios/bin/nagios -d /usr/local/nagios/etc/nagios.cfg
root 7175 0.0 0.0 5004 800 pts/5 S+ 13:16 0:00 grep nagios

Could these be a new bug no one has seen before?

Thanks for the assistance.



Hi Everyone once again,

I fixed the problem. The solution was to forget about the upgrade process and just to backup my current nagios directory and re-compile it with the suggested steps posted on the faq’s found here . It looks like something broke during the upgrade process. However, after compiling it with the following options (this will be pertinent to my 64-bit architecture) , --with-gd-lib and --with-gd-inc, it all worked. Here were the commands that I ran:

make devclean
./configure --with-gd-lib=/usr/lib64 --with-gd-inc=/usr/include
make all
make install

I guess this does then tie into the previous issue of the gd library, I just found it odd that after following the upgrade process and making all the changes manually, that it didn’t work. So if you get stuck, just backup your directory, and compile fresh with the correct directory options and then copy and paste any files or configurations that might be broken.

Thanks Ethan for such a great product and all the hard work that you do. I will get my company to donate as soon as we get some more cash flow this quarter. :smiley: