Nagios 3.0.6 to 3.1.2 (fc10) web problem


#1

Hello,
i just downloaded the new core 3.1.2 and installed it on a 3.0.6 existant one. (on a fedora core 10 )
I followed the upgrade doc , even tried to install from scratch, and i got the same problem once installed : everytime i refresh a page, nagios comes back to main page.

i switched back to 3.0.6 and it’s ok. I suspect the new php files ( main / side /index) to do this, but dont know why.

anyone got same problem or a clue about what does this ? it seems the browser refresh only from host/nagios/nagios instead the real path.

thanks in advance


#2

in some conditions durinmg upgrade (not sure on a fresh install) the installer doesn’t remove the html files, try renaming them to bak or something else and see if the new PHP files work correctly


#3

hi,
i renamed and even deleted the html.
In the first upgrade tho, it wasnt working at all because my nagios was still looking for them.

so i tested a fresh install,and got this weird thing. It’s working , it’s just the refresh of the pages that send me back to main page everytime.


#4

In this case you probably gave a wrong path during the configure phase.
The HTML files should be renamed (or removed) if the php files are present :slight_smile:


#5

the problem isnt from the html files as i re-installed completely the 3.1.2 and i dont have them anymore. To be sure i deleted all the directories before installing a new nagios.

Nagios is working, i have access to all the screens. But when i refresh a screen (for example i press F5 to actualize a service ), i come back to nagios start page (the one with title and such).

drwxrwxr-x 2 nagios nagios 4096 2009-07-31 17:59 ssi
drwxrwxr-x 2 nagios nagios 4096 2009-07-31 17:59 media
drwxr-xr-x 4 root root 4096 2009-07-31 18:00 locale
drwxrwxr-x 2 nagios nagios 4096 2009-07-31 18:07 stylesheets
-rw-rw-r-- 1 nagios nagios 5714 2009-07-31 18:07 side.php
-rw-rw-r-- 1 nagios nagios 26 2009-07-31 18:07 robots.txt
-rw-rw-r-- 1 nagios nagios 3137 2009-07-31 18:07 main.php
-rw-rw-r-- 1 nagios nagios 718 2009-07-31 18:07 index.php
drwxrwxr-x 3 nagios nagios 4096 2009-07-31 18:07 docs
drwxrwxr-x 2 nagios nagios 4096 2009-07-31 18:07 contexthelp
-rw-rw-r-- 1 nagios nagios 576 2009-07-31 18:07 config.inc.php
drwxrwxr-x 2 nagios nagios 4096 2009-07-31 18:07 includes
drwxrwxr-x 3 nagios nagios 4096 2009-07-31 18:07 images


#6

Wait, F5 always brings to the main screen… :confused:

nagios auto updates the pages you are seeing… or you need to click on the correct menu point…


#7

err no , F5 works fine on nagios 2.x and nagios 3.0.6 . Tested and certified. It only does that since the 3.1.2 (and prolly the new php files).


#8

ok sorry :slight_smile:

at least it’s not a config problem… maybe it will revert to old behaviour in the next version :slight_smile:


#9

Same problem with the core 3.2 … no fixe on the php in the changelog…(except the obvious requirement to install it)


#10

This still happens in 3.2.1. Kind of annoying. Anybody know of any workarounds to restore the manual refresh functionality?