Nagios and mysql


#1

Hi,
i have succesfully installed nagios and NSClient++ but i’m trying to install NDOutils
i have created a mysql database “nagios”

i have run :
./configure --with-mysql-lib=/usr/lib/mysql

but when i run
/usr/local/nagios/bin/ndo2db-3x -c /usr/local/nagios/etc/ndo2db.cfg

i get the message :
Support for the specified database server is either not yet supported, or was not found on your system.

i have modified the ndo2db.cfg and nagios.cfg files as mentionned in the documentation

perhaps must i compile nagios with a “mysql” option but i don"t know how to do

Can somebody help me?


#2

hello
i have succeded to recompile NDOutils and run it but i have another problem :

i have now this message in the log:

ndomod: Error writing to data sink! Some output may get lost. 3996
queued items to flush.

The database nagios is empty
Thanks for your help

Thierry


#3

hello

perhaps must i recompile nagios with a mysql option but what is the command?
./configure --with???
Many thanks
Thierry


#4

i just reinstalled nagios and installe dndoutils on it.

There’s no need to have nagios compiled with any particular option.

It all worked almost “out of the box”… the only option i rememebr was the nagios option --with-command-group=nagcmd.