Nagios daemon fails to start


#1

I have a problem starting nagios. Running Solaris 9 sparc. Compiled and installed ok. Pre-flight check is OK, 5 warnings but no errors. Apache starts ok and I can get to the test index page, but get a 404 error when try to load nagios. ScriptAlias and Alias is exactly as in the manual.
I can run …/bin/nagios -d …/etc/nagios.cfg and it creates the lock file ok with pid. Log file shows daemon created and the 5 warnings but no errors.
If I run /etc/init.d/nagios start - get the following message
Starting network monitor: nagios
Usage: su -] username arg …]
PID TTY TIME CMD

then it just goes back to prompt, no PID info.
If I do a ps -ef, there is no [nagios] daemon running.
This is a replacement for our current nagios server so I have checked set up and permissions with current working server. Can’t see the problem.
Any ideas ??
Cheers
Rod.


#2

su - root
enter root password
then run
/etc/init.dnagios start


#3

Sorry…was logged in as root.
But found the problem…2 actually.

  1. Nagios.cfg was trying to write the nagios.cmd file to a unspecified directory. Changed the …/nagios/var directory and worked fine.
  2. The default configure option for cgiurl=/cgi-bin/nagios … but the ScriptAlias in the manual I have, says /nagios/cgi-bin.

Anyway, it is working now.
Cheers
Rod.