Nagios_Grapher - RRDTool Problem


#1

I am running Nagios 3.0 and have just installed nagios_grapher stable (having tried 1.6 first)

Icons and links all working fine ( I think but the RRD files are not getting created. The folder for each host is but the .rrd file isn not. The error I am seeing in the ngraph.log is:

[blockquote]2008-07-17 17:00:27 RRD: rrdtool create step 300 rra 1:300 2:1010 12:770 72:1488 288:744 for /usr/local/nagios/var/rrd/dialin-router/87ee4c416ab169316149fb59685c7ee3.rrd
2008-07-17 17:00:27 RRD: rrdtool create /usr/local/nagios/var/rrd/dialin-router/87ee4c416ab169316149fb59685c7ee3.rrd --step=300 DS:Loss:GAUGE:900:U:U DS:RTA:GAUGE:900:U:U DS:Loss:GAUGE:900:U:U DS:RTA:GAUGE:900:U:U RRA:AVERAGE:0.5:1:300 RRA:MAX:0.5:1:300 RRA:MIN:0.5:1:300 RRA:AVERAGE:0.5:2:1010 RRA:MAX:0.5:2:1010 RRA:MIN:0.5:2:1010 RRA:AVERAGE:0.5:12:770 RRA:MAX:0.5:12:770 RRA:MIN:0.5:12:770 RRA:AVERAGE:0.5:72:1488 RRA:MAX:0.5:72:1488 RRA:MIN:0.5:72:1488 RRA:AVERAGE:0.5:288:744 RRA:MAX:0.5:288:744 RRA:MIN:0.5:288:744 with rra 1:300 2:1010 12:770 72:1488 288:744
2008-07-17 17:00:27 RRD: [dialin-router][PING]:Duplicate DS name: Loss
[/blockquote]

Anyone any ideas on what is causing this and more importantly how to resolve?

Thanks

M


#2

Are you using check_ping or check_icmp to do the check? I seem to recall having to change to check_icmp when I installed something similar because the check_ping plugin won’t output perfmon data…


#3

Thanks for the reply. I’ve given that a go but still the same. No rrd files being created.


#4

hmm, don’t know then. Looks from the error that it is trying to create 2 datasources with the same name (for Loss & RTA) for your dialin-router’s PING graph. If this is due to the configuration then ensure all of your data source names are unique… if it is something the plugin is picking up from nagios then I’m not sure how it can be solved


#5

Weird. does nagios_grapher use a map file with a bunch of regex in it to make the rrd’s? does the regex that matches ping output have duplicate data source names (Loss & RTA) for some reason?