Nagios host dont update


#1

Last night, one of my server (server A) was down and when it was already up, it was still red (HOST STATUS DOWN) even though the service ssh is now ok in that server. When i checked the status.log, it shows that :

HOST;SERVERA;DOWN;1131262985;1131206895;0;950927;0;0;1131206895;1;1;1;1;1;0;0.00;0;1;1;CRITICAL - Plugin timed out after 10 seconds
SERVICE;SERVERA;SSH;OK;1/5;HARD;1131262981;1131263161;ACTIVE;1;1;1;1131207025;0;OK;950928;0;0;129;0;0;1;0;0;1;0;0.00;0;1;1;1
;SSH OK - OpenSSH_3.9p1 (protocol 1.99)

In my webinterface, service status (ssh) is ok but host status (serverA) is down. I received an email saying it was down last night but after 1 hour, it goes back to normal but since then host status never change only the service status (ssh) is ok. i checked /var/spool/mail/nagios and it is 0 bytes.

i also tried to do pre-flight check and it found no error

Checking global event handlers…
Checking obsessive compulsive service processor command…
Checking misc settings…

Total Warnings: 0
Total Errors: 0

Things look okay - No serious problems were detected during the pre-flight check

I hope someone can help me with this problem.


#2

The notification interval is 120. BUt still i dont received any email stating that this server A is down. 8 hours has past but still no email, host status dont change.


#3

service.cfg of SERVER A

define service{
host_name SERVER A
service_description SSH
is_volatile 0
check_period 24x7
max_check_attempts 5
normal_check_interval 3
retry_check_interval 3
contact_groups NOC-admins
notification_interval 60
notification_period 24x7
notification_options c,r
check_command check_ssh!22
}

hosts.cfg of SERVER A

define host{
host_name SERVER A
alias SERVER A
address 192.168.0.125
check_command check-host-alive
max_check_attempts 10
notification_interval 120
notification_period 24x7
notification_options d,u,r
parents CISCO_ROUTER_2600
}


#4

nagios version is?
If it’s not v1.2 or below, I won’t be repliing.