Nagios install problem freebsd 5.4


#1

Hi all thanks for any help.

freebsd 5.4
nagios-1.3

I’m having an install problem, I’ve read most of the doc’s and followed the instructions to the “t” and I’m getting this error on make install-init

nagios# make install-init
/usr/bin/install -c -m 755 -d -o root -g root /usr/local/etc/rc.d
install: root: Invalid argument
*** Error code 67

made nagios directory /usr/local/nagios
made the group nagios
made the user nagios
and tied both to the directory

configure went fine
make all went fine
make install went fine
make install-config went fine
then when I ran make install-init I got the above error

did all this from root

been working on this almost a week and I’m just chasing my tail, I just want to monitor my small hosting network 11-12 servers.

Thanks again for any help
Robb


#2

did you have any warnings during configure? looks like install uses an option which BSD doesn’t like…

Luca


#3

man install on your bsd should tell you.


#4

Thanks for the hepl you guys, Luca no I did’nt have any errors or messages on configure here is my configure statment:
./configure --prefix=/usr/local/nagios --with-cgiurl=/nagios/cgi-bin --with-htmurl=/nagios/ --with-nagios-user=nagios --with-nagios-grp=nagios

went fine,

Jake this was a manual install, and i had no errors up till make install-init

Thank again
Robb


#5

still, you need to look at
man install
and see what options bsd has for install.
It looks like to me, that ./configure messed up in figuring out what options it can use for install. You may have had errors during ./configure
But anyway, just copy the init script from the src folder. i.e. daemon-init to the location of your init scripts.
or edit the makefile in your src and run make install-init again. i.e.Makefile and change the line "
INIT_OPTS="
to whatever fits bsd’s liking.
Edited Fri Feb 10 2006, 09:44PM ]


#6

Thanks Jake that did it, Iam getting some other small errors but will
sort through the later.

Again thanks your the top!!
Robb