Nagios login, ubuntu hoary


#1

hi, having problems setting up nagios i have installed it on a server at school, which has apache2 i can get to the secure login page, but it does not accept the username and password.

the username being nagiosadmin, and password being one i chose during install.

i have tryed reinstalling as well but to no avail, can anyone suggest some possible causes, i am trying to access it on the localhost machine.

i installed nagios via a synaptics repository, and it has set everything up auto matically including the username and password, just i cant login and have no idea where to look to resolve the problem, i did try recreating the user from the console but could still not login.

any ideas ?


#2

nagios.sourceforge.net/docs/1_0/cgiauth.html


#3

thanks for the link, i tried adding this to apache.conf (using apache2)

ScriptAlias /usr/lib/cgi-bin/nagios/ /usr/sbin/
<Directory “/usr/sbin/”>
AllowOverride AuthConfig
Options ExecCGI
Order allow,deny
Allow from all

Alias /etc/nagios/ /usr/lib/nagios/
<Directory “/usr/lib/nagios/”>
Options None
AllowOverride AuthConfig
Order allow,deny
Allow from all

how ever this seems to make little difference and is likely wrong, the paths in the ubuntu version of nagios are all very different i have tried to correct them the best i can but am going on guess work mainly so could be wrong.

like i am unsure what the cgi-bin folder is, i have guessed /usr/lib/cgi-bin/nagios/
i am also unsure where /usr/local/nagios/share maps to ?

can any one help or perhaps post the relevant config for ubuntu ?


#4

Never heard of ubuntu. It sounds like it’s some rpm install or something, so most of us here will not be of much help. My suggestion is to uninstall the rpms and then install from source, following the nagios documentation that is VERY thorough and complete.


#5

AFAIK ubuntu is a live CD distro based on Debian…
If it really is a live CD you almost impossibly can run nagios on it…

Luca