Nagios on Plesk Installation Trouble (Apache 403 Forbidden E


#1

Hello everyone :(.

Yesterday I naively attempted to install Nagios on a Plesk server running RHEL4 using the Fedora Quickstart instructions available here:
http://nagios.sourceforge.net/docs/3_0/quickstart-fedora.html

I skipped the prerequisites step because Plesk already has Apache installed, gcc, gd and the other prerequisites installed.

In Step 5, Configuring the Web Interface, I held off on the last step which asked to restart Apache, (“service httpd restart”).

I continued all the way until Step 7, started Nagios, and then it was at this point that I restarted Apache.

I immediately went our main website to see if everything was OK…and unfortunately it wasn’t.

For every page I received a 403 Forbidden Error with the message “You don’t have permission to access / on this server” (or whatever other folder I tried to access).

I checked permissions on the files (in Plesk all httpdocs folders have to belong to the psaserv group and all files and folders within the httpdocs folders need to belong to the psacln group) and everything checked out. The default permissions for the httpdocs folders in Plesk is 750, and the only way I was able to get the sites back up was to change the permissions manually to 751, but that’s not a real fix.

I thought the problem was caused by the nagios.conf file that was added into the conf.d folder, but after I removed that and restarted Apache the problem still persisted.
Then I stopped the service and tried removing Nagios using the following thread: http://www.meulie.net/portal_plugins/forum/forum_viewtopic.php?5676.0#post_9464

And then I restarted Apache but that didn’t seem to work either.

Then I thought maybe the user/group nagios/nagcmd was causing an issue but after removing those the problem still continued.

At the moment all I want to do is to remove Nagios completely and get my Plesk setup operating normally again and then I’ll continue playing with Nagios (but this time on a Virtual Machine setup, not my production environment like a knucklehead).

Any help anyone can provide is tremendously appreciated because Plesk support won’t touch this since Nagios is not supported by them.

Thank you :(.


#2

Some additional information:
http://www.nagios.org/faqs/viewfaq.php?faq_id=118&expand=false&showdesc=false

The Nagios FAQ article above is supposed to help with machines that are using Suexec. I don’t really know whether Plesk is using it or not (running the command to check whether it is on my machine says that it isn’t) but within the Plesk folder there is a folder named suexec so I’m wondering if that might be related to the problem.


#3

I ran a search here in the Plesk forums (perhaps I should have done that first) and found the following thread:
http://forum.swsoft.com/showthread.php?t=22639&highlight=nagios

And found a solution to the issue.

The problem was that Nagios had deleted apache from the psaserv group so the solution was to run:
usermod -G psaserv apache

Restart apache using:
/etc/init.d/httpd restart

And everything was back in business :frowning: