Nagios-plugins-1.4.13 cant install - pg_config_manual.h: No


I’ve just downloaded nagios and I’m trying to install on a RH Linux Server that has been set up for me. the install of Nagios went fine and I can access the system via Apache. however I can’t install the nagios plug-in

The OS is Red Hat Enterprise Linux AS release 3 (Taroon Update 9)

The configure looks to run OK but the make fails…

if gcc -DLOCALEDIR="/usr/local/nagios/share/locale" -DHAVE_CONFIG_H -I. -I. -I… -I… -I…/lib -I…/gl -I…/intl -I/usr/include/ldap -I/include -I/usr/include -I/usr/kerberos/include -g -O2 -MT check_pgsql.o -MD -MP -MF “.deps/check_pgsql.Tpo” -c -o check_pgsql.o check_pgsql.c;
then mv -f “.deps/check_pgsql.Tpo” “.deps/check_pgsql.Po”; else rm -f “.deps/check_pgsql.Tpo”; exit 1; fi
check_pgsql.c:44:30: pg_config_manual.h: No such file or directory
make[2]: *** [check_pgsql.o] Error 1

I’ve tried installing various products ti try and fix this so that if I list what is installed then I get this.

rpm -q -a | grep -y sql

Any Ideas what is causing this


Probably the RPM does not include the pg_config_manual.h file (or did not simlink it properly) - 7.3.19 is quite an old version, the latest version available on the postgre YUM repository is version 8.4. Sadly though, your platform version is unsupported by the repository which only goes back as far as RHEL4, and I can’t find anything remotely useful on any of the generic repositories I’ve tried, there just isn’t that much available for RHEL versions < 4.

I’d upgrade your OS if I were you. RHEL5 is out you know… :wink: