Nagios refuse to start with event_broker_options=-1


#1

Hi,
I’m french so my english isn’t very clear but I hope you can understand me.

I have just installed cacti, nagios and oreon in the company where i work.

Indeed, I currently try to couple these two last (cacti and nagios) with“npc”.

I followed the instructions of the README (compilation of Nagios with the option --enable-vent-broker, patch of cacti, displacement of the file inserter in the directory of nagios, and addition of the 3 options in nagios.cfg :

  • retain_state_information=0
  • event_broker_options=-1
  • broker_module=/usr/local/nagios/modules/inserter.o

But nagios refuse to start with “event_broker_options=-1”, although it is compiled with “–enable-event-broker”.

I am desperate, please help.

Thx
ced