Nagios Runs Slow


#1

Hi Guys,

Am currently running nigios to monitor our servers. However, nagios seems to move kinda slow going through it checks. Say I have a service setup to be checked every 1 minute and 5 times before a notification is sent. You will think this will take about 5 minutes. This actually takes about 20 minutes because nagios takes quite a long time before it gets back around to check the service. I also niticed some strange warnings in the log which I think may be the cause of this problem. Any suggestions on how I can tune nagios will be helpful. See the log entries below.

[1158856421] Warning: The results of service ‘Apache’ on host ‘www.domain.com’ are stale by 31 seconds (threshold=82 seconds). I’m forcing an immediate check of the service.
[1158856421] Warning: The results of service ‘Tomcat’ on host ‘www.domain.com’ are stale by 31 seconds (threshold=82 seconds). I’m forcing an immediate check of the service.
[1158856521] Warning: The results of service ‘WEBMAIL’ on host ‘mail’ are stale by 35 seconds (threshold=180 seconds). I’m forcing an immediate check of the service.
[1158856622] Warning: The results of service ‘ping’ on host ‘host017’ are stale by 36 seconds (threshold=280 seconds). I’m forcing an immediate check of the service.
[1158856622] Warning: The results of service ‘SSH’ on host ‘host016’ are stale by 36 seconds (threshold=280 seconds). I’m forcing an immediate check of the service.
[1158856722] Warning: The results of service ‘homepage’ on host ‘domain.com.au’ are stale by 35 seconds (threshold=381 seconds). I’m forcing an immediate check of the service.
[1158856722] Warning: The results of service ‘ssh’ on host ‘host01’ are stale by 136 seconds (threshold=280 seconds). I’m forcing an immediate check of the service.


#2

You have fresshness checking enabled, and is used with passive setups/distributed nagios installs. So, are you using passive checking or not? If not, disable freshness checking for those services.
I don’t think you should be checking services every 1 minute. That’s a bit of a overkill, and will make your nagios setup work too hard. 5 minutes should be sufficient.