Nagios service_check_timeout not working


On faq I read that plugin’s default time out is 10 seconds.
I have a self made plugin. it’s a simple bash script. Because of connection latency it take a bit more than 10 seconds to execute.
But this is self made so there should not be any timeout set! It should fall in timeout when it reach the service_check_timeout limit that is defined in the main configuration file.
But it does it before…

Why is this value ignored?

I didn’t find much searching on the net, only this.
I don’t find it clear. I tried to use negate insiede my command definition and it make it appear the service green but still with** “CRITICAL - Plugin timed out while executing system call”.**

define command { command_name check_ssh_bkp command_line $USER1$/negate -t 60 $USER1$/check_by_ssh -l extensys -H $HOSTADDRESS$ -p $_HOSTPORT$ -C "" }

Any idea?

I’m working on debian lenny
inside /etc/nagios3/nagios.cfg
the value of service_check_timeout is 60.


You need to also set the timeout in the nagios config file.


May you be so gentle to tell me wich file and wich option?


inside /etc/nagios3/nagios.cfg
the value of service_check_timeout is 60.[/quote]