Nagios startup error!


#1

I have isntalled nagios 2.0rc2 and tried starting the daemon with basic default configuration. I have got the following error.

==============
root@linu init.d]# ./nagiso start
Starting network monitor: nagios
CONFIG ERROR! Start aborted. Check your Nagios configuration.
root@linu init.d]#

Need help in identifying the issue. I have not mae any change in the default settings. Tried starting nagios with default settings.
:slight_smile:
Roopesh


#2

/$nagiospath/bin/nagios -v /$nagiospath/etc/nagios.cfg

check for errors :slight_smile:

Luca


#3

I have installed Nagios 1.3.
With /$nagiospath/bin/nagios -v /$nagiospath/etc/nagios.cfg all is ok and with /$nagiospath/bin/nagios /$nagiospath/etc/nagios.cfg Nagios starts perfectly, but if I try to view the status via browser, it return the message “Internal Server Error - The server encountered an internal error or misconfiguration and was unable to complete your request”.
I have enebled authorizations in the cgi.cgf file and I modified the http.conf file as well as indicated in the documentation.

Sorry for my English


#4

[quote=“carletto”]I have installed Nagios 1.3.
With /$nagiospath/bin/nagios -v /$nagiospath/etc/nagios.cfg all is ok and with /$nagiospath/bin/nagios /$nagiospath/etc/nagios.cfg Nagios starts perfectly, but if I try to view the status via browser, it return the message “Internal Server Error - The server encountered an internal error or misconfiguration and was unable to complete your request”.
I have enebled authorizations in the cgi.cgf file and I modified the http.conf file as well as indicated in the documentation.

Sorry for my English[/quote]

Did you remember to restart both Nagios and Apache after making those configuration changes?


#5

Btw, if you authenticate successfully into Apache, and it’s just that you’re having trouble with accessing the CGIs, then your configuration error isn’t about authentication. Apache returns an “Error: Forbidden” message when authentication fails.

Would you please post the relevant portions of your cgi.cfg file and your .htaccess files?


#6

Yes, I did


#7

cgi.cfg:

main_config_file=/usr/local/nagios/etc/nagios.cfg
physical_html_path=/usr/local/nagios/share
url_html_path=/nagios
show_context_help=0
use_authentication=1
authorized_for_system_information=nagiosadmin
authorized_for_configuration_information=nagiosadmin
authorized_for_system_commands=nagiosadmin
authorized_for_all_services=nagiosadmin
authorauthorized_for_all_service_commands=nagiosadmin
authorized_for_all_host_commands=nagiosadmin
authorized_for_all_hosts=nagiosadmin
default_statusmap_layout=5
default_statuswrl_layout=4
ping_syntax=/bin/ping -n -U -c 5 $HOSTADDRESS$

.htaccess:

AuthName "Nagios Access"
AuthType Basic
AuthUserFile /usr/local/nagios/etc/htpasswd.users
require valid-user

Edited Wed Jan 18 2006, 06:38PM ]


#8

is this part of httpd.conf setup?

criptAlias /nagios/cgi-bin /usr/local/nagios/sbin

<Directory “/usr/local/nagios/sbin”>
Options ExecCGI
AllowOverride None
Order allow,deny
Allow from all
AuthName "Nagios Access"
AuthType Basic
AuthUserFile /usr/local/nagios/etc/htpasswd.users
Require valid-user

mainly the execcgi line…

Luca


#9

Yes, it is.
however I replaced it with your indication, I restarted apache and nagios then I tried again, but nothing changes.


#10

Did you cut/paste from what Luca put? That post is missing the “S” in “ScriptAlias”, so that could give you problem.

I assume you’ve also placed the the alias for your share/ folder in httpd.conf, and in the correct location in relation to the ScriptAlias for the sbin/ directory, yes?


#11

I noted the imperfection to :frowning:


#12

I’ve found an easy solution: installing nagios-2.0rc2!
Thanks to all