Nagios stop failed



I am little bit new with Nagios and try to set it up, when i change a configuration i need to reload or restart nagios.
When i do a reload or restart or even stop, i get a failed notification in red.

i googled about this problem but the solutions , changing in your nagios.cfg the lock file does not help.
Its probaly something doeing with permissions, but i have not the knowledge to set the permission the right way and also being secure ( so no 777)

Can anyone help me with this problem?


Did you install from source or RPM?
If you installed from RPM try installing from source.


no is used the cactiEZ cd, so it installs Cacti and nagios.


ok some more information.
When i stop or reload nagios i get this:

[code][root@localhost init.d]# /etc/init.d/nagios stop
nagios (pid 3996) is running…
Stopping nagios: pidof: invalid options on command line!

pidof: invalid options on command line!



could there be something wrong with the init.d/function?




looks like the init script isn’t the nagios standard one… or it’s an old one…

it’s something in the options used for pidof… check the script check the pidof man page and see what’s up :slight_smile:


Wel i did a new install from source of nagios and that solved this problem, but a new problem evolved. It does not see the statusmap.cgi.


can you see other graphs? could be a missing gd library…



Did you install this prequisite? : **libgd2-xpm-dev

Can you find statusmap.cgi on the location where is has to be?