Nagios version 3.0.2 problem with viewing trends


#1

Hi,
I am having some dificulties with viewing trends in nagios. If I go directly to service that I want to view trends for, it shows me trends for last 24 hours. However if I try to change report period to any other value I get “It appears as though you are not authorized to view information for the specified service…” message. If i try to do the same by going to trends link and set up report from there I get same error message immidiatelly. Interesting thing though is that I am able to to trend report for any time period on following: HTTP, SSH, Uptime, explorer. I get error message if I try to trend following: drive space, cpu load, memory usage, current load, current users etc…

I did some digging myself and I noticed that this problem was to be fixed in 3.0.1

Can anyone help with this problem. Any suggestion is much appreciated.


#2

I’m having the exact same issue, I’m using 3.0.2…


#3

Hi,

It seems that nagios encode its URL twice, so you have this error message only if your host contain special chars.

Example :
mydomain:myhost

The URL should be written like this :
mydomain%3Amyhost

However, nagios reencode the URL :
mydomain%253Amyhost

I guess the %25 code means “%”. The trends CGI get “mydomain%3Dmyhost” instead of “mydomain:myhost”.

Replace all %25 by % in your URL, and you should get your report.


#4

yes you are correct
I was getting this url:
myipaddress/nagios/cgi-bin/trend … day&zoom=4
I changed it to:
myipaddress/nagios/cgi-bin/trend … day&zoom=4

However, problem does not seem to be with my hostname rather it is + sign in “CPU+Load” part that gets changed to %2B. If I change this manually to + I will get my report. I will see what I need to change in order to have it work from page without me fiddeling with url. I shall report my findings.
Thank you for your input it was of much help.


#5

I just renamed 3.02 trends.cgi to trends.302 thencopied the 3.01 trends.cgi into the folder - now it works again.


#6

i’ve just installed the 3.0.3 but the ‘Trends’ problem is still there.
In particular i get a 'It appears as though you are not authorized to view information for the specified service…'
message when trying to display results not in the default period (yesterday, this week …)
and the service name contains spaces (Uptime is OK, Cpu Load is not working).
Has anyone experimented such a problem ?


#7

Installed 3.0.3 and Trends for anything but default range.
Copied the 3.0.1 trends.cgi file again and VOILA - it is working again. Not a solution, a simple workaround,