NagiosGrapher


#1

Hi there,

Server: Linux version 2.6.11-6mdksmp
Nagios: Nagios 2.0b4
RRD: RRDtool 1.2.11

I’ve just configured NagiosGrapher, like it’s described under nagios-wiki.de/doku.php/nagi … iosgrapher, but I’ve just received following error:

Some error occured:

RRD Error: invalid rpn expression in: /home/nagios/var/lib/rrd/Denic-Server/…
Values:
CDEF: Loss=/home/nagios/var/lib/rrd/Denic-Server… .rrd:Loss:AVERAG

…]

Thats my ngraph.cfg:

# cat ngraph.cfg # Nagios Grapher Configuration File... ######################################

System wide Configuration

define config {
pipe /home/nagios/var/lib/ngraph.pipe
rrdpath /home/nagios/var/lib/rrd/
serviceext_type MULTIPLE
serviceextinfo /home/nagios/etc/serviceextinfo.cfg
serviceext_path /home/nagios/etc/serviceext
url /cgi-bin/graphs.cgi
nagios_config /home/nagios/etc/nagios.cfg
icon_image_tag dot.png’ border=“0”><img src="/images/logos/graph.png" border="0"
log_file /home/nagios/var/log/ngraph.log
log_level 63
}

Ping Packet loss

define ngraph{
service_name PING
graph_log_regex loss = ([0-9]*)
graph_value Loss
graph_units %
graph_legend Packet Lost
page Packet Lost
rrd_plottype LINE2
rrd_color ff0000
}

Ping RTA

define ngraph{
service_name PING
graph_log_regex rta = ([0-9].[0-9])
graph_value RTA
graph_units ms
graph_legend Time to answer
page RTA
rrd_plottype AREA
rrd_color 00a000
}

Load CDEF definition

define ngraph{
service_name LOAD
type CDEF
graph_value cdef_load
graph_source 15m CPU Load,5m CPU Load,1m CPU Load
graph_units
graph_legend
graph_calc +,+
rrd_plottype LINE1
rrd_color 000000
hide no
}

Load GPRINT definition

define ngraph{
service_name LOAD
type GPRINT
print_source cdef_load
print_description Latest
print_function LAST
print_format %lf
}

Load GPRINT definition

define ngraph{
service_name LOAD
type GPRINT
print_source cdef_load
print_description Maximum
print_function MAX
print_format %lf
}

Load GPRINT definition

define ngraph{
service_name LOAD
type GPRINT
print_source cdef_load
print_description Average
print_function AVERAGE
print_format %lf

Can any1 help me to solve the problem, please?
Edited ]