Ndoutil compile, 64-bit rhel5


#1

Attempting to compile ndoutils on 64-bit rhel5.

Confirmed mysql (and mysql_config) location at /usr/lib64/mysql

./configure --enable-mysql --with-mysql=/usr/lib64/mysql --with-mysql-lib=/usr/lib64/mysql

Getting…

checking for mysql_init in -lmysqlclient… no

*** MySQL library could not be located… **************************

You chose to compile NDOutils with MySQL support, but I was unable to
locate the MySQL library on your system. If the library is
installed, use the --with-mysql-lib argument to specify the
location of the MySQL library.
installed, use the --with-mysql=DIR argument to specify the
location of the MySQL library, We assume mysql_config is in DIR/dir
NOTE: After you install the necessary libraries on your system:
1. Make sure /etc/ld.so.conf has an entry for the directory in
which the MySQL libraries are installed.
2. Run ‘ldconfig’ to update the run-time linker options.
3. Run ‘make devclean’ in the NDBXT distribution to clean out
any old references to your previous compile.
4. Rerun the configure script.

TIP: Try the following…
./configure --with-mysql=/usr/lib/mysql


nagios version is 3.2.0
ndoutils version is 1.4b9

Any assistance GREATLY appreciated.


#2

not sure how it may be called in RH but you are missing the mysql-client libraries. on debian the package is mysql-client-5.0 (or mysql-client for older versions).


#3

Hey all,

I don’t know if it’s OK to rehash an old subject like that, but I’m having the exact same problem.

I am running Ubuntu (10.04_x86), I have mysql installed as well as the mysql-client-5.1 libraries. I tried adding /usr/lib/mysql in the /etc/ld.so.conf file, as well as running ldconfig (as suggested in the error report) but I am still getting the same error at configure. Any idea why it’s not detecting mysql ?

Thanks.


#4

see if there is a DEV package for libmysqlclient


#5

I installed dev package, but nothing has changed. What’s the proper way to debug such a problem ?


#6

no idea, it’s usually just a missing package, running debian i haven’t had any problems… but ubuntu shudl be very similar.


#7

I know this is an old thread, but I had the same issue in Ubuntu Server 12.10. The solution was to install “libmysqlclient-dev” (aptitude install libmysqlclient-dev).