Network unstable


#1

Hey all, well this is the situation:
2 Guests running Windows on top of Debian using Backports (2.6.32bpo.5 kernel, 0.12.5 KVM)
Thing is network.
They’re using a bridged network, so they can use a public IP I’ve aquired from my ISP.
However, at some random times, network will just fail.
The fact of it being random isn’t the problem, the problem is that it’s pretty constant.
From 24 hours, it sometimes is connected to the internet (guests and host) for 2 hours.
I don’t see anything in /var/log, dmesg doesn’t show any error, nor br0 changing states.
Windows guests are running Server 2003 R2, with Virtio drivers from XP for both network AND storange.
The network is the troublesome part.
When network goes down (to the outside world down) the guests and the host can still ping each other.
I’m aiming at a bug, or a problem with the ISP.
But I need information on how to further diagnose the issue.
For the record, the NIC that’s connected to the outside world is a Realtek-based Gigabit Ethernet card, and it’s connected to a Cisco modem (low end, can’t tell the exact model now).
Memory is more than enough, swap is never touched.
Guests are using each one a Logical Volume for their own.
What can I do to further diagnose the issue?
What could be the problem? Has anyone ever experienced this?


#2

Hey, same here.

  • Lenny 2.6.32-bpo.5-amd64

lspci | grep Eth
03:05.0 Ethernet controller: D-Link System Inc DGE-528T Gigabit Ethernet Adapter (rev 10)
03:06.0 Ethernet controller: D-Link System Inc DGE-528T Gigabit Ethernet Adapter (rev 10)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)

brctl show
bridge name bridge id STP enabled interfaces
vlan1br 8000.20cf30287f58 no eth0
vnet1
vnet2
vlan2br 8000.00265abf9583 no eth1
vnet3
vlan5br 8000.20cf30287f58 no eth0.5
vnet0

eth0 is the onboard-card (RTL8111/8168B…)

DomU1 works well with bridged networking (vnet0 + vnet1)
DomU2 works well with vnet2. vnet3 has a public ip (doesn’t matter) and doesn’t work

lsmod | grep r81
r8169 28669 0
mii 3210 1 r8169

When i turn STP on for vlan1br and start the DomU, i can ping it until the “topology change timer” from brctl showstp stops at zero.

So whats wrong there?


#3

I just kept thinking of the interfaces you were using were correspondant to the scheme of Xen :slight_smile:
I solved it using routing.
My provider was having problems acknowledging my hosts if I was using bridge.
So I used a tap adapter for each guests, added a route to them, and attached a MAC address to my ARP table correspondent to my WAN-connected device.
This seems to be working well enough.
Someone suggested that the bridge setup was also causing a broadcast storm, thing that I’m not willing to think right now on how to solve since it’s working.


#4

I did not saw a broadcast storm.

The funny point is, sometimes the ping works thru the public interface and sometimes not. Sometimes the ARP-Replies arrive at the vnet interface, they always arrive at the bridge interface. Maybe there are problems with

i) timing - forward Delays
ii) bad Realtek-Drivers for the physical interface, they are also used for the guests (but doens’t matter, if virtio/e1000/rtl)

i don’t like to use Routing/NAT. It makes it more complicated / wastes a public.

I will try it again with an LTS Release of Ubuntu, maybe it helps


#5

Routing and NAT don’t go by hand.
In my case, I attached each guest to a tap device, and then a route to the outside.
They use their own public IP.
And it was in MY case that someone suggested that.
For what’s worth, I also changed from Virtio on Windows guests to e1000, and that was part of the solution, though with virtio, routing them, and adding the ARP entry manually (arp -Ds {GUEST_IP} {INTERFACE} pub).
In my case, it would work, however they’d loose conectivity every once in a while.
Now, in my case at least it’s all solved.
Also you keep refering to DomU, is it that you’re used to Xen terminology? Because for KVM, those are guests.