Newbee Question -->check_procs: Unknown argument - (null


#1

I installed Nagios 2.0 on Linux

In the file ‘checkcommands.cfg’ the command ‘check_local_procs’ defined as

‘check_local_procs’ command definition

define command{
command_name check_local_procs
command_line $USER1$/check_procs -w $ARG1$ -c $ARG2$
}

In the file ‘minimal.cfg’ I have a service defined as follows:

define service{
use generic-service ; Name of service template to use
host_name localhost
service_description Total Processes
is_volatile 0
check_period 24x7
max_check_attempts 4
normal_check_interval 5
retry_check_interval 1
contact_groups admins
notification_options w,u,c,r
notification_interval 960
notification_period 24x7
check_command check_local_procs!250!400
}
When I run from the command line, it seems OK:
[root@nagios libexec]# ./check_procs -w 250 -c 400
PROCS OK: 59 processes
But when I start a web page, I am getting
"check_procs: Unknown argument - (null) "


#2

After I killed the Nagios process (before that I tried only to restart the nagios service), I’ve got rid of this “Unknown argument” message.