(No output!) message in the browser


#1

Guys

I just upgraded to Nagios 2.0.b and I have a little problem. I was able to start Nagios without problems (though going through the config files was a bit hard as I have a few hosts and services monitored) but I run to a little problem. I get (No output!) message in the Web Interface. I get this error for these services that I’m monitoring with self configured checkcommand that worked fine in Nagios 1.0.3. The command is as follows:

‘check_interfejs’ command definition

define command{
command_name check_interfejs
command_line $USER1$/check_ifoperstatus -H $HOSTADDRESS$ -C $ARG1$ -d $ARG2$
}

check_ifoperstatus plugin works from the command line so I’m a bit confised. Have you had such problems? Perhaps you have a clue?


#2

So that is the checkcommaned definition, so what is the service definition for a service that uses this check_interfejs command? Also, what is the $USER1$ defined as in the resource.cfg or minimal.cfg or whatever you are using?


#3

#TEMPLATE DEFINITION
define service{
name serwis
is_volatile 0
check_period 24x7
max_check_attempts 10
normal_check_interval 15
retry_check_interval 1
notification_interval 0
notification_period 24x7
notification_options w,u,c,r
register 0
}

#SERVICE DEFINITION
define service{
use serwis
host_name router
service_description Link
contact_groups telco
check_command check_interfejs!snmp_key!Serial0/1
}

These are the service definitions (template and service)

And this is my resource file:

Sets $USER1$ to be the path to the plugins

$USER1$=/usr/local/nagios/libexec


#4

then run this by hand logged in as nagios user.
/uar/local/libexec/check_snmp -H ipaddy -C snmp_key -d Serial0/1

Does that work?


#5

Before trying your option I have installed nagios plugins 1.4 and this solved the problem. This gives me a lesson that if I ever upgrade nagios I have to upgrade plugins as well.

Thanks Jakkedup for your help because the clue to my problem was check_snmp plugin which was not included to my previous version of nagios plugins.