Nrpe 2.0


#1

Hello
I have nagios 1.2 and i have installed nrpe 2.0.my Os fedora 2.0.
when i installed nrpe2.0 on my server,i read the readme file.in that it is given that nrpe daemon and nrpe.cfg should be placed somewhere on remote host.Can nebody tell me who is experienced wth nrpe that where this somewhere to be installed…
heres wht is in readme file

Installing

The check_nrpe plugin should be placed on the Nagios host along
with your other plugins. In most cases, this will be in the
/usr/local/nagios/libexec directory.

The nrpe program and the configuration file (nrpe.cfg) should
be placed somewhere on the remote host. Note that you will also
have to install some plugins on the remote host if you want to
make much use of this addon.

I have copied check_nrpe to my /usr/local/nagios/libexec dir on server.

Thanks
Aparna


#2

hello

i have Copied the nrpe daemon to /usr/sbin.


#3

hello

i have Copied the nrpe daemon to /usr/sbin.Also i have copied the sample nrpe.cfg config file to /etc.
now what do i have to do next to get it wrking?.Like about check load and other commands/

Aparna


#4

hello
My checkcommands.cfg file contains

define command{
command_name check_nrpe
command_line $USER1$/check_nrpe $HOSTADDRESS$ -c $ARG1$
}

define command {
command_name check_local_load
command_line $USER1$/check_load -w $ARG1$ -c $ARG2$
}

AND MY Services.cfg contains

define service{
use generic-service ; Name of service template to use

    host_name               host.mnrgig0a02.com
    service_description     LOAD
    is_volatile             0    
    check_command           check_local_load!15,10,5!30,25,20   
    }       

Now want to know where nrpe comes here in activatiosn.And how do i check load,and check_disk?
plz reply bck

from
Aparna


#5

Hello

I am now getting
CHECK_NRPE: Error - Could not complete SSL handshake.

what do i do for this.
plz help me out.i am going nuts with this.
Aparna


#6

Check the “allow_host” parameter in your nrpe.cfg.
the value should be the ip adres of your nagios machine.

Another problem could be the port you


#7

hi
Thanks for ur help.
now when i type the following cmd,i get this msg.

[email protected] [/usr/local/nagios/libexec]# ./check_nrpe -H IP address -p 5666
CHECK_NRPE: Socket timeout after 10 seconds.

this i am giving from my application server.

thanks plz help me

wht do i do
Aparna


#8

Hello there
now i have started getting again the following error
CHECK_NRPE: Error - Could not complete SSL handshake.


#9

Hi
I have installed nrpe without ssl support
when i run check_nrpe command manually on the shell of my remote host i get the err.

[email protected] [/bin]# ./check_nrpe -H HOSTADDRESS
CHECK_NRPE: Error receiving data from daemon.


#10

And from my monitoring host i get the socket timeout err


#11

Hope it will help you.

Install nrpe-2.0
cd /home/hashar/nrpe-2.0/
./configure && make .
The binary is /home/hashar/nrpe-2.0/src/nrpe , plugin is /home/hashar/nrpe-2.0/src/check_nrpe

Update the daemon for all hosts:

cp /home/hashar/nrpe-2.0/src/nrpe /home/wikipedia/nagios/bin/
Now from larousse update the check_nrpe plugin:

cp /home/hashar/nrpe-2.0/src/check_nrpe /usr/local/nagios/libexec/
Don’t forget to check the global configuration: /home/wikipedia/nagios/etc/nrpe.cfg .

Ashar launched the daemon on all apaches using:

dsh -f -N apaches
-e ‘/home/wikipedia/nagios/bin/nrpe -c /home/wikipedia/nagios/etc/nrpe.cfg -d’


#12

if didn’t then tell me ur configuration…may be i will be of further assistance.


#13

Hey Thanks for your help
I will try out and let u knw if i have ne probs

Thanks once again
Aparna


#14

hi i have tried wht u said but no luck
well this is my config

#check_nrpe command definition
define command{
command_name check_nrpe
command_line $USER1$/check_nrpe $HOSTADDRESS$ -c $ARG1$ -to 90
}

Service definition

define service{
use generic-service ; Name of service template to use

    host_name                       HOSTNAME
    service_description             LOAD
    is_volatile                     0
    check_period                    24x7
    max_check_attempts              3
    normal_check_interval           3
    retry_check_interval            1
    contact_groups                  nagios
    notification_interval           120
    notification_period             24x7
    notification_options            w,u,c,r
    check_command                   check_nrpe!check_load
    }

i am getting
LOAD

UNKNOWN 05-05-2005 03:27:30 1d 1h 9m 46s 3/3 Incorrect command line arguments supplied

wht do i need to do so tht i can monitor load and diskspace on remote host

Thanks


#15

From the error you get, it looks like you have “Incorrect command line arguments supplied” so double check your syntax.


#16

Hello when i run this command from shell u get the following error

./check_nrpe -H HOSTADDRESS -p 5666 -c check_load

CHECK_NRPE: Socket timeout after 10 seconds.

What can be done for this
Thanks


#17

./check_nrpe -H HOSTADDRESS -p 5666 -c check_load

Check the syntax again for the check_nrpe command. I seriously doubt that -H HOSTADDRESS is valid. Looks to me, like it should be some ip address, but I could be wrong.


#18

ya you are right .sorry my mistake by hostaddress i meant ipaddress.
i entered ipaddress only but i get the above err…
Thanks
Aparna


#19

According to the README file, there are many items that you might have NOT done. I’d suggest to read the README file that came with nrpe, and make sure that you have completed each and every step. Did you restart xinetd, is just one example of a step you might have missed.


#20

Hi
xinetd is to be restarted if i am not running nrpe as deamon on remote host is it right?
So i didnt do nethng wth xinetd coz i am running nrpe as deamon.
wht can be done

Thanks for helping me
Aparna