NRPE config error *SSL*


When installating NRPE on SPARC Solaris 10 I’m getting an error after ./configure:

checking for SSL headers… SSL headers found in /usr/local/ssl
checking for SSL libraries… configure: error: Cannot find ssl libraries

I’ve installed openssl with all default settings but it still complains…anyone got any idea??

#2 … olaris-10/


Checked that page out and went through all the steps, everything compiled/installed correctly, however when I test the check_nrpe plugin I get another error related to ssl: check_nrpe: fatal: open failed: No such file or directory

I’ve installed openssl, but to no avail…nothing is coming up in /usr/lib related to ssl.

Any ideas?


I had the same issue on centos. Fixed it by installing openssl-devel


I’m now getting a different error message:

CHECK_NRPE: Error - Could not complete SSL handshake

I’ve tried editing the nrpe.c file as suggested on the nagios site, to no avail.

Has anyone overcome this problem???


Make sure that:

  1. That your client machine is listening on port 5666
  2. You created the nagios user and that it owns


I’ve re-compiled using --disable-ssl to avoid any further problem with ssl, but now I’m getting the:

CHECK_NRPE: Received 0 bytes from daemon.

when I run : ./nrpe -n -c /usr/local/nagios/etc/nrpe.cfg -d

when I ps -ef | grep nrpe all I’m getting is:

nagios 5175 5129 0 09:40:30 pts/6 0:00 grep nrpe

which indicates me daemon isn’t even running.

I’ve compiled exactly as the guide in url above said, but I’m still getting errors, even if the service says it’s only under smf.

Any ideas?