NRPE - Could not complete SSL handshake (again)


Hi all-
Everything was running perfectly on all my servers in regards with NRPE for the last 6-7 months. Now all of a sudden, I came into work and am rec’ing errors from one host that says “CHECK_NRPE: Error - Could not complete SSL handshake.”. Restarting the service as well as the server didnt help. Same goes for the nagios server. I was using NRPE 2.10 on both servers so I upgraded to v2.12 (current). Im still getting the SSL handshake errors. I dont get it…it was working fine then all of a sudden it stops. The remote server has not been touched in a couple weeks so it makes it a little more confusing. Anything I can try to troubleshoot it? I ran through the FAQs on Nagios’s site with no luck




as you have figured it, this error comes with SSL encryption … so, the “best” way to avoid any troubles is to disable it :slight_smile:
So yes, that’s the last resort way, but when you’ll be bored trying to solve this problem, re-compile your nrpe with option “–disable-ssl” and problem solved :slight_smile:

in the meantime, you can try to do a “ldd nrpe” (and also a “ldd check_nrpe” on the server, but that shouldn’t be a problem if only one host is affected) to see if all the librairies are present.
You can also try to re-install openSSL on the client …

but still, if all fails, just use “–disable-ssl” :wink: