Nrpe doesn't seem to be used by nagios


Hi all, first, here are my specs:
Debian (testing) with:
Nagios 2.10
NRPE Plugin for Nagios 2.8.1
plugins 1.4.8-2.2

RedHat LE3
with a source compiled NRPE version 2.8.1 from the debian source package for compatibility.

I am not using SSL, or at least I don’t think I am.

My problem is that I can run the following from the nagios host as the nagios user and get a return:

$ /usr/lib/nagios/plugins/check_nrpe -n -H rhle3 -c check_users USERS OK - 1 users currently logged in |users=1;5;10;0

I ran the command using tcpdump and got a result:

# tcpdump -i eth0 host rhle3 and port 5666 tcpdump: verbose output suppressed, use -v or -vv for full protocol decode listening on eth0, link-type EN10MB (Ethernet), capture size 96 bytes 10:25:46.893631 IP > rhle3.nrpe: S 2247562885:2247562885(0) win 5840 <mss 1460,sackOK,timestamp 571949 0,nop,wscale 4> 10:25:46.902047 IP rhle3.nrpe > S 1757565253:1757565253(0) ack 2247562886 win 64240 <mss 1460> 10:25:46.902101 IP > rhle3.nrpe: . ack 1 win 5840 10:25:46.902480 IP > rhle3.nrpe: P 1:1037(1036) ack 1 win 5840 10:25:46.902678 IP rhle3.nrpe > . ack 1037 win 64240 --snip--

So to me, all is well. I setup a couple of checks for the RedHat box but this is the error I get for all my plugins:
[blockquote]No output returned from plugin[/blockquote]

I ran tcpdump for an hour as above and got no traffic what so ever so it looks to me like nagios is not even trying to use nrpe.

Can you help? I did not post my config files to avoid a massive mail and because nagios doesn’t seem to complain about them, but if you want them, I can send them.

Many thanks


Well; I think you should post some parts of your config files, because it seems it might come from there
(try to post at least your command definition)


Hi guys,
I’ll get back to you on this problem in a few days/weeks. I just became a dad and my time on line is now /dev/null.

Thanks for your help.


Hi all,

I found the problem but thought I should ‘document it’ in case someone else is as… well, tiered as I am…

I changed

define command { command_name check_nrpe command_line /usr/nagios/libexec/check_nrpe -H $HOSTADDRESS$ -c $ARG1$ -a $ARG2$ }with

define command { command_name check_nrpe command_line /usr/nagios/libexec/check_nrpe -n -H $HOSTADDRESS$ -c $ARG1$ }
See ya