NRPE_NT - "UNKNOWN: No handler for that command"


#1

I’m a bit new to Nagios, and especially NRPE, so forgive me if I’m doing something obviously wrong:

I’m running Nagios on a Linux server, and I’m trying to monitor the output of a script on a Windows XP Pro machine. I’ve installed NRPE_NT on the Windows machine, configured the IP accordingly, and added a command that runs the script called “check_evt”:

I’ve added this line services definition on the Nagios server’s services.cfg file:

In Nagios, I’m getting this error as a result:

I’ve also tried using the included test.cmd, and the same error results. I don’t see any evidence on the Windows client that the check_evt command is actually being run (I added a line to the script to log to a file for testing).

Any ideas?

Thanks


#2

Have you defined NRPE handlers sections in NSC.ini on windows box?


#3

I don’t see that file - googling for it, I found that file is associated with NSClient++, but that’s not what I’m using. Do I have to create it for NRPE_NT?


#4

Then you have nrpe.cfg, and in it you have command definitions under which you have to define commands which you will use. There are examples in it, so it shouldn’t be a problem to figure out how to add your check commands.


#5

He means nrpe.cfg…
[blockquote]# COMMAND DEFINITIONS

Command definitions that this daemon will run. Definitions

are in the following format:

command<command_name>]=<command_line>[/blockquote]


#6

Is there something wrong with the syntax of the command in my first post?

(command[check_evt]=C:\Program Files\NRPE_NT\bin\check-evt.py)


#7

Do you have python installed on your Windows machine?

Unless you don’t, install it, and yes then there is something wrong with the command syntax. You have to specify that this should be run by python, for example, if you have installed python and it’s executable is in in C:\bin\python, then command syntax should be like this:
command[check_evt]=C:\bin\python C:\Program Files\NRPE_NT\bin\check-evt.py


#8

Thanks for replying. Python is installed, and it’s in the system path, so that command should work - it works if I paste it in to “Run”. I tried it with the syntax you suggested, but I’m getting the same result. If I try using the included test.cmd, that results in the same “UNKNOWN: No handler for that command” error, so I’m guessing there’s a problem other than that particular line in nrpe.cfg.


#9

Hm, have you checked if nrpe_nt service is started on your windows machine?
Do you have check_nrpe command defined anywhere in your nagios configuration?


#10

The service is running, and the check_nrpe command is defined in the nagios config on the server. Running the check_nrpe command from the server command line results in the same error as well.


#11

Hm, I’m not really some expert with nrpe-nt. Have you tried to do what you want with the NSClient?
As I see, nrpe_nt is :
Current Version: 0.8
Current Status: Beta

Maybe some bug or something… Or maybe you just need to reinstall it and recheck all your conf. files… Sorry, if I find some possible solution to your problem I will post it…