NRPE problem under SOLARIS



I’ve installed NRPE 2.12 under SOLARIS 10 X86, everything seems OK, but when I tried

./check_nrpe -H localhost / Nagios Server IP

it returned

CHECK_NRPE: Error - Could not complete SSL handshake.

In fact, I’ve cherched in google for serveral days, and I’ve done all that I can, but nothing changed.

I installed NRPE as inetd service, and

svcs svc:/network/nrpe/tcp:default -> online 15:53:39 svc:/network/nrpe/tcp:default
netstat -a | grep nrpe -> *.nrpe . 0 0 49152 0 LISTEN
netstat -an |grep 5666 -> *.5666 . 0 0 49152 0 LISTEN

… the others, also OK. (tcp_wrappers = TRUE, hosts.allow, hosts.deny, …)

Besides, when I tried

telnet localhost 5666 ->

Connected to localhost.
Escape character is ‘^]’. nrpe: fatal: open failed: No such file or directory
Connection to localhost closed by foreign host.

but, LD_LIBRARY_PATH=/usr/sfw/lib:/usr/lib:/usr/local/lib,

and I’ve done

ldd check_nrpe -> =>       /usr/sfw/lib/ =>    /usr/sfw/lib/ =>   /usr/lib/ =>        /usr/lib/ =>     /usr/lib/ =>    /usr/lib/ =>    /usr/lib/ =>   /usr/lib/ =>  /usr/lib/ =>         /usr/lib/ =>   /usr/lib/ =>         /usr/sfw/lib/ =>      /usr/sfw/lib/ =>     /usr/lib/

so, I’m really confused.

Any one can help me ? :x


When I had the same problem I used the instructions I found here: … l-support/

One thing I’d add is that I ended up having to build nrpe on the non-Sun machines with the same cipher list changes so they could all talk to each other.