NRPE problem


#1

hi

i’m getting this error when trying to use check_nrpe plugin on my nagios machine,

CHECK_NRPE: Received 0 bytes. Are we allowed to connect to the host?

i already edited the nrpe.cfg on the remote host to allow my nagios server.

what else do i need to configure?

thanks


#2

Didn’t you just ask that question? How many are you going to start on this topic? Which one you going to work with us in?


#3

hi, can you give me any ideas why i’m keep getting this problem. thanks


#4

Dude, which one of these threads are you with? You’ve got too many about the same thing. Please tell us which one and stick with it. I won’t help you until then.
Edited Mon Jan 16 2006, 03:12AM ]


#5

sorry but this is the only topic i had for nrpe. can you help me pls. ty


#6

Okay…well, there’s more to it than just the allowed_hosts param. You have to check the port you have specified to allow the traffic on, then make sure that the check command in Nagios is using that port. Then you have to make sure there’s nothing standing between Nagios and the port on the remote host, like your Iptables and firewall configuration.

Also, SElinux may or may not hamper your ability to use NRPE.
Edited Mon Jan 16 2006, 03:18AM ]


#7

hi,

i’m using using solaris and i don’t have any firewall.

when i do a ps -a |grep nrpe on the remote host, this is what i got

*.nrpe . 0 0 32768 0 LISTEN

i already define the specific port on /etc/services
nrpe 5777/tcp

and allowed the ip of my nagios monitoring server in the hosts.allow config

do i miss something else? thank you.


#8

Oh, are you running NRPE under inetd? I’m not familiar with that setup. Not sure how much I’d be able to help you. But it looks like NRPE is indeed running.


#9

is somebody there using nrpe under inetd? need help pls. ty


#10

hi,
whenever i’m executing the ./check_nrpe to the nagios server

i’m getting this error on the /var/adm/messages on the remote host

Error: Request packet had invalid CRC32. pls help. thanks


#11

Try googling the error messages you’re getting. I’ve found a couple of fixes to my problems that way.


#12

I’m using nrpe with xinetd without any major problems.

1.) On the remote machine, ou have to make sure to have any neccesary libraries needed for the plugin to work.

2.) include the port number in /etc/services

3.) set up a inetd entry which starts nrpe

4.) edit nrpe.cfg to reflect your plugin needs.

I think problems with the whole thing can only be solved with tools like strace (linu:evil: or truss (solaris).
Or maybe you’ll see some additional infos when looking at the network traffic with snoop or tcpdump.

For example, i had a problem that for some reason, the shell which is invoked on the remote machine tries to read root’s .bashrc and has no success. So it says “/root/.bashrc : permission denied”. And thats all the plugin ever said since nagios likes the first line of output only …
So i had to allow the nagios user to read roots .bashrc.

Have you ever tried to run the plugin on the remote machine? which output do you get?


#13

hi,

the plugin is running fine on the remote machine. how do i allow the nagios user to read the roots .bashrc ?
thanks


#14

That’s a Unix issue involving permissions. You could execute from command line chmod o+r .bashrc. That will give any user on the box read permissions to that file.

I don’t know the role of .bashrc, though…so I don’t know whether or not that’s a good idea, or if there’s something else about it that would prevent anyone except root from doing anything with/to it.
Edited Wed Jan 18 2006, 04:45AM ]


#15

.bashrc was already had read permission to others. i’m still not allowed to connect to host.

im getting this error from the remote machine,

Error: Request packet had invalid CRC32

i think it’s not related to the shell permission anymore

pls help
Edited Wed Jan 18 2006, 07:01AM ]


#16

Oh…I was wondering why you’d asked that question. I’ve not seen that error before. Have you tried using the forum search for the term CRC32?


#17

CRC32 error was gone though, but i got a new error from the remote machine

Host xxx.xxx.xxx.xx is not allowed to talk to us!

the nagios server was defined on the nrpe.cfg already but i’m getting this message

CHECK_NRPE: Received 0 bytes. Are we allowed to connect to the host?

do i miss something else?

thanks
Edited Wed Jan 18 2006, 11:36PM ]


#18

What *NIX distro is that remote machine running, and is iptables running on it?


#19

its using sol9 and no firewalls yet installed.


#20

help pls ty