NRPE: Unable to read output


#1

I’m running NRPE 2.3.

I read a lot of post in this forum and also a lot of messages in many many mailing list and newsgroup.

I tried with all the solution concerning files permission.

The output of my syslog is:
Feb 9 13:14:59 LinuxSAM nrpe[12623]: Connection from 10.28.3.63 port 63362
Feb 9 13:14:59 LinuxSAM nrpe[12623]: Handling the connection…
Feb 9 13:14:59 LinuxSAM nrpe[12623]: Host is asking for command ‘check_users’ to be run…
Feb 9 13:14:59 LinuxSAM nrpe[12623]: Running command: /usr/local/nagios/libexec/check_users -w 5 -c 10
Feb 9 13:14:59 LinuxSAM nrpe[12623]: Command completed with return code 3 and output:
Feb 9 13:14:59 LinuxSAM nrpe[12623]: Return Code: 3, Output: NRPE: Unable to read output
Feb 9 13:14:59 LinuxSAM nrpe[12623]: Connection from X


#2

Can you show us how you’ve set up your nrpe check commands and the part from your services.cfg file that’s referencing this command?


#3

Hi all.

I just solved.

The problem was that I haven’t installed the plugin in the remote host.
In manydocuments was written that I have to installa check_nrpe on the server anc the NRPE deamon on the client.
Than I’ve to install the plugin on the server! (There’s also a drawing with two red box for the plugins that are installed on the server!!)
Now I’ve installed and compiled the plugins also on the client and I’ve also enabled SSL support and xinetd.

Now, it works fine.

Thanks a lot.


#4

Ah, so that’s what it is. I had seen that error before but forgotten what it meant. I’ll have to do my best to remember it this time.