NSClient++ SysTray doesn't work


#1

Hello

I wanna monitor Windows machne, and I’ve dowloaded NSClient++ I followed the instructions in the Nagios.pdf file and whn I get to the “NSClient++ SysTray” comand in cmd it deosn’t work. It says:
Invalid comand line argument: Systray
Usage: -version, -about, -install, -uninstall, -start, -stop, -encryp
Usage: -noboot] [arguments]

so I type “nsclient++ SysTray -start” and I get these lines:
Exception raised: Could not load library: 126: Thied module could not be found
…and so on for all .dd files in the directory

What’s wrong?

Thanx


#2

Seee, this is most important: "Invalid comand line argument: Systray"
Maybe you should write:
nsclient++ systray.dll -start
I haven’t tried it, but if it doesn’t work with how I advised you to, try to write the exact path to .dll module


#3

I’ve tried and this is wha I get:
"Module was not loaded, attempt to load it
Thread already started, thread not started…

This application has requestd the Runtime to terminate it in an unusual way.
PLease contact the application’s support team for more information.

And then I get the Windows Send/Donst send error messege…


#4

I’ve also stumbled on this isue. I found that it should be " nsclient++ SysTray install " (SysTray is case-sensitive). This seems to work on winXP but doesn’t on Win2k3. Monitoring the Win2k3 works fine though, even without the SysTray. I think the systray.dll needs to be turned of in the NCS.ini to avoid errors.


#5

I’m hoping that this is a valid answer? I’m coming from a Big Brother environment, which took a lot of time and patience to learn, configure, etc. We were hoping for a different experience with Nagios, and it seemed pretty simple to get the server up and running. Trying to learn what Nagios support options was somewhat painful, but I finally found the “unofficial forum” here, and the mailing lists. I guess it’s similar to Big Brother’s archived mailing list for their Better Than Free option. I’m really not looking forward to spending another 6 months learning all the ins and outs of every aspect of Nagios in the same way. If so, I should just have stuck with BB.

So that being said, the first thing I try doing is getting the NSClient++ running on W2K3 boxes, and getting the systray to work. Straight out of the documentation it doesn’t work, and I see a post somewhere that mentioned running NSClient++ SysTray install, which seemed to work with the following error:

nsclient++ SysTray install
NSClient++.cpp(533) Attempting to start NSCLient++ - 0.3.7.493 2009-10-12 e \SysTray.cpp(51) SysTray is not installed (or it cannot interact with the desktop) SysTray won't be loaded.  Run NSClient++ SysTray install to change this.  SystemTray is no able to run as the SERVICE_INTERACTIVE_PROCESS flag has been set.  NSClient++.cpp(1281) Failed to set settings fileNo settings manager found have you configured.

This was after first running nsclient++ /install of course. It’s telling me to do something, that I AM doing. I’m not able to find anything regarding the error about the fileNo settings, nothing. If it just doesn’t work on 2K3, it should be easier to confirm with a Google search, but nada… I’m just getting started, and the forum searching has begun…