Openssl on Suse9.2 and check_http


#1

I am using Suse 9.2 pro with nagios v2.
Up complied openssl 0.9.8 with ./config shared then complied the nagios plugins with ./configure --with-openssl=/usr/local/ssl

All seemed well and compiled ok but when I tried ./check_http -? i get this

./check_http: error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory

the file is there by the way !!! maybe not were it is expecting it !!! I do not know.

Nagios was working fine for plain old http checking till I tried to check for HTTPS…
I have also tried ./configure --with-open=/usr/local/ssl/includes/openssl

still does not work !!!

Could anyone point me in the correct direction or should this be more a SuSE issue ???

I am nearly there in my setup and config… just this stupid openssl issue is causing me a few other issues…

Thanks
Gareth

:roll:


#2

meulie.net/forum_viewtopic.php?21.1997


#3

Thanks jakkedup… that has fixed the error but it has not fixed the fact that I am unable to check HTTPS Sites.
I will try to recompile the plugins now the /lib is ok.

If it works I will post back… untill then any more ideas ??

THanks
g


#4

I do not get it… It did not work !!! What could I be doing wrong ???
Any other way to check HTTPS anyone ???


#5

I just did ./check_http --help and it says it will connect to ssl servers, so what’s the error, what’s the problem, what’s the syntax you used, what’s the…


#6

Hi jakkedup,

I now have a test box at home and think I figured this out.
Nagios is running on SuSE 9.2 Pro, Nagios 2.0b3

noticed that at home after doing all the above it still did not work !!! Still gave me " ./check_http: error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory"
I then did a FULL update… still nothing.

One other thing that was suggested some other place (Foget where, think it was here!!!) was to create a symbolic link to the file…

ln -s /usr/local/ssl/lib/libssl.so.0.9.8 libssl.so.0.9.8

then did ./check_http --help and all looks good…
One thing to note you may get a libcrypto error… do the same ln -s…

As a note I did this at work but then removed it when it did not help… so it looks to be a combination of things that work…

Thanks jakkedup for the help. Hope I help others !!!
G