Perl plugins - "global symbol" errors



am running Nagios 1.3 on SuSe Enterprise 9.

I have downloaded some plugins that rely on Perl. I have Perl (5.8.3).

When I run the checks from terminal - they work.
When I run the same check from inside Nagios I get “no output”.

I stopped Nagios in daemon mode and started it logged in as root. Then I could see the errors…

I get - Global symbol “$variablename” requires explicit package name at (eval x:evil: line xxx

The variablename and line numbers are in the check.

I have been digging to see if I missed telling Nagios about perl, but I can’t see what I missed…

Any ideas ?



nagios has no interest in knowing if the plugin is perl or compiled or what else as long as the nagios user can execute the plugin you shouldn’t have problems… try su - nagios and try running the plugin from command line, possibly it’s a permission issue.



Hi Luca,

I did the reverse - ran nagios logged in as root (not as a daemon). Wouldn’t that give nagios root permissions - same as me running the check command line ?

The command line works as root - but not from inside Nagios.

I did check permissions on the check - everyone has read and is marked executable.

I am just about to leave for the day - will try su as nagios tomorrow.