PID and LOG files are amply,but nagios proces running


#1

the web interface is not showing any of my hosts or services and gives me this error when trying to look at the service detail:

"There doesn’t appear to be any service status information in the status log…

Make sure that Nagios is running and that you have specified the location of you status log correctly in the configuration files."

I get a similiar error when looking at the host groups only it says “hosts status” instead of “service status”

I’ve looked around and it seems that most people get this error when Nagios isn’t running or when the nagios.log and/or status.dat are pointed to incorrectly in the main configuration file.

I’ve restarted nagios and verified the config by runnning " /usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg" and everything checks out fine. I’ve tried to reboot the server but I’m still getting the same error.

Also, I checked both "/usr/local/nagios/var/status.dat and /usr/local/nagios/var/nagios.log (which are the locations specified in nagios.cfg) and they are completely empty. Any ideas why this is?

Forgive me if this is a stupid question. Up until now I haven’t had any major issues with it and unfortunately I took over someone else’s install of it so I’m not familiar with it inside and out.

Any advice would be greatly appreciated.

and
when i provide

Quote:
[[email protected] ~]# service nagios restart
Running configuration check…done.
Stopping nagios: kill: usage: kill -s sigspec | -n signum | -sigspec] pid | jobspec … or kill -l [sigspec]
done.
Starting nagios: done.
[[email protected] ~]# /etc/init.d/nagios status
nagios is not running
[[email protected] ~]# service nagios start
Starting nagios: done.
[[email protected] ~]# /etc/init.d/nagios status
nagios is not running

I’m sure Nagios is running but nagios.lock , nagios.log , retention.dat , status.dat are empty!
I don’t understand what is the problem!
why nagios don’t write nothing in this files?