Ping problem


#1

Hi i am getting this status information for host when any service is down.
whts the problem with ping?

Host Status: DOWN
Status Information: /bin/ping -n -U -c 1 IP address

Aparna


#2

Hi,
I have tried fpinf also instead of check_ping but still no luck.well i want my nagios to monitor services and host.i have installed nagios 1.2.My problem is whenever service for any host goes down it (nagios)shows my host down too when it is not.my check host command is check_ping/fping.please guide me on what check host command to give so that my host is not shown down when one of my service is down.Are there any other settings to be made for check_ping to work properly?

Thanks
Aparna


#3

hello
To make ping wrk properly do we have to make some changes or additions in iptables or sysctl.conf

Aparna


#4

if you only check ping and it fails it MUST show the server as down (this has been told already three times)
Try giving a higher timeout.

Luca


#5

Ok this is my check-host-alive command.
what can you suggest about timeout

define command {
command_name check-host-alive
command_line $USER1$/check_ping -H $HOSTADDRESS$ -w 3000.0,80% -c 5000.0,100% -p 1
}


#6

you only make one ping…
make it “-p 5” and add “-t 15” and see what happens.

Luca


#7

thanks Luca
I will try it out
Sorry for bothering u so much.
Regards
Aparna


#8

Hi Luca
I tried with -t 15 but no luck :frowning:
Also can you tell me why does it shows
Host Status: DOWN
Status Information: /bin/ping -n -U -c 1 IP address

Thanks
regards
Aparna


#9

sorry no idea about the status info… can’t make a test today…

possbily somebody else knows.

Luca


#10

Ok Thanks
but if you come to know abt ne solution for this do let me know.
thanks for your help
Aparna


#11

I ahve the same problem but I’ve come up with ./configure script for plugins. It has an option --with-ping-command I have to play with it as my /bin/ping doesn’t support -U option. Haven’t figured it out yet but try searching there and feed me back :wink: if you’ll find it


#12

Hi RooG
i tried to change with ./configure but no use.what ping syntax did u entered in ./configure script.Let me knw.
If i get the solution i will paste it here.
thanks for ur help


#13

If -U is not accepted, then change the check_ping define in the file checkcommands.cfg to not include it.


#14

try it on shell —
cd /your/plugin/directory
./check_ping -H hostname -w 3000.0,80% -c 5000.0,100% -p 3

If it works for you then the plugin is ok. Otherwise the pluging is bad.
try by replaceing check_command from check-host-alive to check_ping
in your hosts.cfg file.