Plugin time more than 10s -> CHECK_NRPE: Socket timeout a


#1

Hello everybody,

Can someone help me?
Nagios and my host are corectly working viz NRPE.
But for one of my plugin, I have a problem. This one takes 12s for the result:
Jul 3 11:02:22 eclipse nrpe[3489]: Connection from 192.168.0.41 port 12695
Jul 3 11:02:22 eclipse nrpe[3489]: Host address is in allowed_hosts
Jul 3 11:02:22 eclipse nrpe[3489]: Handling the connection…
Jul 3 11:02:22 eclipse nrpe[3489]: Host is asking for command ‘check_teststb’ to be run…
Jul 3 11:02:22 eclipse nrpe[3489]: Running command: /home/nagios/test.sh
Jul 3 11:02:34 eclipse nrpe[3489]: Command completed with return code 0 and output: TEST OK
Jul 3 11:02:34 eclipse nrpe[3489]: Return Code: 0, Output: TEST OK
Jul 3 11:02:34 eclipse nrpe[3489]: Connection from 192.168.0.41 closed.

SO as we can see the result is OK but on my nagios, I have : CHECK_NRPE: Socket timeout after 10 seconds. for this service but the others are correct.

Can I increase the timeout? Ond which one is it? which file?
I try everything but I still have this problem.

Or I create into the cron a test and my service will just check for the result of this one.
But I will have a lot of that kind of test to do.

Thanks


#2

You can increase the timeout using the **-t **parameter in your check_nrpe command object definition on the nagios server…

[code][root@localhost libexec]# ./check_nrpe --help

NRPE Plugin for Nagios
Copyright © 1999-2008 Ethan Galstad (nagios@nagios.org)
Version: 2.12
Last Modified: 03-10-2008
License: GPL v2 with exemptions (-l for more info)
SSL/TLS Available: Anonymous DH Mode, OpenSSL 0.9.6 or higher required

Usage: check_nrpe -H -n] -u] -p ] -t ] -c ] -a <arglist…>]

Options:
-n = Do no use SSL
-u = Make socket timeouts return an UNKNOWN state instead of CRITICAL
= The address of the host running the NRPE daemon
[port] = The port on which the daemon is running (default=5666)
[timeout] = Number of seconds before connection times out (default=10)

…[/code]

HTH

/S